<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8) ]><!-->
<html lang="en-US"  xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<!-- Google Chrome Frame for IE -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1, user-scalable=0" />

	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://soaps.sheknows.com/xmlrpc.php" />
	
<!--
		 _     _ _           ____          _          _____ _    ___
		| |   (_) | _____   / ___|___   __| | ___    | ____| |__|__ \
		| |   | | |/ / _ \ | |   / _ \ / _` |/ _ \   |  _| | '_ \ / /
		| |___| |   <  __/ | |__| (_) | (_| |  __/_  | |___| | | |_|
		|_____|_|_|\_\___|  \____\___/ \__,_|\___( ) |_____|_| |_(_)
												  |/

		 Work on Soaps.com and other iconic brands!

		 Visit our careers page at https://pmc.com/careers/

-->

<meta name="description" content="General Hospital&#039;s Steve Burton (Jason Morgan) taped a sweet Christmas duet with his daughter and shared a video for fans." />
<meta name="keywords" content="General Hospital, News, Amy Mistretta" />
<meta name="news_keywords" content="GH, Jason Morgan, Steve Burton" />

<title>General Hospital&#8217;s Steve Burton&#8217;s (Jason Morgan) Sweet Christmas Duet With His Daughter, Video | Soaps.com</title>
<script type="text/javascript">dataLayer = window.dataLayer || []; /* Google Tag Manager */</script>
<script type="text/javascript">
/* <![CDATA[ */
var pmc_meta = {"lob":"","page-type":"single-news","env":"desktop","primary-category":"","primary-vertical":"","vertical":"","category":"","tag":["GH","Jason Morgan","Steve Burton"],"author":"","logged-in":"","subscriber-type":"","country":"us","is_eu":false,"post-options":""};

/* ]]> */
</script>
		<script type="text/javascript" class="optanon-category-C0002">
			(function(d,w){
				var i, parts, name, c, rdecode = /(%[0-9A-Z]{2})+/g, rspace = /\+/g, ac = (d ? d.split('; ') : []);
				for(w.pmc_cookies = {}, i = 0; i < ac.length; i++) {
					parts = ac[i].split('='), name = parts[0].replace(rdecode, decodeURIComponent), c = parts.slice(1).join('=');
					if(c.charAt(0) === '"') { c = c.slice(1, -1); } c = c.replace(rdecode, decodeURIComponent).replace(rspace, ' '); w['pmc_cookies'][name] = c;
				}
			})(document.cookie, window);

			pmc_meta=pmc_meta || {}, pmc_meta.omni_visit_id = window.pmc_cookies.omni_visit_id || "pmc." + new Date().getTime() + '.' + (function(l,b,a,c,i,d){for(i=0;i<256;i++){l[i]=(i<16?'0':'')+(i).toString(16);}if(c&&c.getRandomValues){try{d=new Uint32Array(4),c.getRandomValues(d);}catch(e){d=0;}}d=d||[b()*a>>>0,b()*a>>>0,b()*a>>>0,b()*a>>>0];a=d[0],b=d[1],c=d[2],d=d[3];return l[a&0xff]+l[a>>8&0xff]+l[a>>16&0xff]+l[a>>24&0xff]+'-'+l[b&0xff]+l[b>>8&0xff]+'-'+l[b>>16&0x0f|0x40]+l[b>>24&0xff]+'-'+l[c&0x3f|0x80]+l[c>>8&0xff]+'-'+l[c>>16&0xff]+l[c>>24&0xff]+l[d&0xff]+l[d>>8&0xff]+l[d>>16&0xff]+l[d>>24&0xff];})([],Math.random,0x100000000,window.crypto||window.msCrypto);
			var d = new Date(); d.setTime(d.getTime() + ( 60 * 60 * 1000 )); var expires = d.toGMTString(); var path = "/"; var domain = window.location.hostname;
			document.cookie = 'omni_visit_id=' + encodeURIComponent(pmc_meta.omni_visit_id) + ( expires ? '; expires=' + expires : '' ) + ( path ? '; path=' + path : '' ) + ( domain ? '; domain=' + domain : '' );
		</script>
				<script type="text/javascript">
		if( window.hasOwnProperty( 'pmc_meta' ) ) {
			if( !window.hasOwnProperty( 'dataLayer' ) || !window.dataLayer.hasOwnProperty('push') ) {
				window.dataLayer = [];
			}
			window.dataLayer.push( pmc_meta );
		}
		</script>

		<meta name='robots' content='max-image-preview:large' />
		<script>
			window.pmc_is_adblocked = false;
		</script>
		<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//content.jwplatform.com' />
<link rel='dns-prefetch' href='//ads.blogherads.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Soaps.com &raquo; Watch General Hospital&#8217;s Steve Burton Team Up With His 7-Year-Old Christmas &#8216;Angel&#8217; on a Heartwarming Holiday Duet Comments Feed" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/feed/" />
<noscript><link rel='stylesheet' id='fallback-all-css-0' href='https://soaps.sheknows.com/_static/??-eJyVkN1OwzAMhV+IzO3EUG8Qj4LcxNsMzo/idKhvv9Aw0UkgdXc58fmO7ANfyXCwMjlSsKrgWAuMEu2nER4z5hm0zEI7z2FXDU+wJj4UPDlGEvIUyp1IgjNlI3RCO2/D62yt7yAbQ/n2JJlOHBSSt2b91mgZxegZM5kRM7yPE4tbjjrmBXabwxLmEuryanMUAVSl0vppP6Z1sjWObPS+4Q9x6Ly57BfwJv8OKOdamMKF008XmNTsu364rd66OFb7fzs8FMH1oBjDb9Sbf+1fnrvuMPT9cAWMNt5q' type='text/css' media='all' />
</noscript><link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='all-css-0' href='https://soaps.sheknows.com/_static/??-eJyVkN1OwzAMhV+IzO3EUG8Qj4LcxNsMzo/idKhvv9Aw0UkgdXc58fmO7ANfyXCwMjlSsKrgWAuMEu2nER4z5hm0zEI7z2FXDU+wJj4UPDlGEvIUyp1IgjNlI3RCO2/D62yt7yAbQ/n2JJlOHBSSt2b91mgZxegZM5kRM7yPE4tbjjrmBXabwxLmEuryanMUAVSl0vppP6Z1sjWObPS+4Q9x6Ly57BfwJv8OKOdamMKF008XmNTsu364rd66OFb7fzs8FMH1oBjDb9Sbf+1fnrvuMPT9cAWMNt5q' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='pmc-adm-style-inline-css'>
div.admz, div.admz-sp { margin-left: auto; margin-right: auto; text-align: center; } #skin-ad-inject-container { display: none; }
</style>
<link rel='stylesheet' id='soaps-main-css-css'  href='https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/css/main.css?ver=1640058118' media='all' />
<noscript><link rel='stylesheet' id='fallback-all-css-2' href='https://soaps.sheknows.com/_static/??/wp-includes/css/dashicons.min.css,/wp-includes/js/thickbox/thickbox.css?m=1639688214' type='text/css' media='all' />
</noscript><link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='all-css-2' href='https://soaps.sheknows.com/_static/??/wp-includes/css/dashicons.min.css,/wp-includes/js/thickbox/thickbox.css?m=1639688214' type='text/css' media='all' />
<link rel='stylesheet' id='soaps-single-css-css'  href='https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/css/single.css?ver=1640058118' media='all' />
<noscript><link rel='stylesheet' id='fallback-all-css-4' href='https://soaps.sheknows.com/wp-content/mu-plugins/jetpack-10.4/css/jetpack.css?m=1638912376g' type='text/css' media='all' />
</noscript><link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='all-css-4' href='https://soaps.sheknows.com/wp-content/mu-plugins/jetpack-10.4/css/jetpack.css?m=1638912376g' type='text/css' media='all' />
<script type="text/javascript" src="https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-global-functions/js/pmc-utils.js?ver=2021.4"></script>			<script type="text/javascript">
			var pmc_do_analytics_pagecount = true;		//flag to allow analytics code to count a page view
			var pmc_common_urls = {
				parent_theme_uri: 'https://soaps.sheknows.com/wp-content/themes/vip/pmc-core-v2/',
				current_theme_uri: 'https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/',
				fb_channel_uri: 'https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/partner/facebook/channel.html',
				pmc_larva_uri: 'https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-larva/_core'
			};
			</script>

		<script type="text/javascript" class="">
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
					(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
				m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			var pmc_ga_dimensions = {"dimension11":"soaps.sheknows.com","dimension16":"2021-12-24","dimension18":"7","dimension19":"","dimension20":"GH|Jason Morgan|Steve Burton","dimension25":"2021-12","dimension26":"1640327411","dimension28":"Watch General Hospital's Steve Burton Team Up With His 7-Year-Old Christmas 'Angel' on a Heartwarming Holiday Duet","dimension29":"618351","dimension31":"Amy Mistretta","dimension33":"show-news","dimension35":"8352","dimension36":"soaps","dimension43":"https:\/\/soaps.sheknows.com\/general-hospital\/news\/618351\/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video\/","dimension113":"single-news","dimension115":"618351","dimension116":"Amy Mistretta","dimension118":"gh|jason-morgan|steve-burton","dimension122":"2021","dimension123":"12","dimension124":"24","dimension125":"06","dimension126":"30","dimension137":"2021-12-24T11:30:11+00:00","dimension138":"2021-12-24 06:30:11","dimension139":"Friday","dimension141":"anonymous"};var pmc_ga_mapped_dimensions = {"skm-domain":"11","skm-channel":"12","skm-subchannel":"13","skm-channellv3":"14","skm-channellv4":"15","skm-publish-date":"16","skm-author-id":"18","skm-content-type":"19","skm-tags":"20","skm-geo-targeted":"21","skm-slideshow-slidenum":"22","skm-slideshow-slideid":"23","skm-slideshow-slidename":"24","skm-publish-month-year":"25","skm-publish-timestamp":"26","skm-article-title":"28","skm-article-id":"29","skm-author-name":"31","skm-article-type":"33","skm-ad-unit-lv1":"35","skm-ad-unit-lv2":"36","skm-local-timestamp":"40","skm-raw-page-url":"43","skm-slideshow-length":"102","skm-pageview-id":"103","skm-recirculation-path":"112","page-type":"113","page-subtype":"114","id":"115","author":"116","category":"117","tag":"118","vertical":"119","primary-category":"120","primary-vertical":"121","publish-year":"122","publish-month":"123","publish-day":"124","publish-hour":"125","publish-minute":"126","protocol":"127","paywall-entitlement":"128","paywall-sub-level-required":"129","paywall-sub-roadblock-hit":"130","paywall-acct-type":"131","paywall-acct-id":"132","paywall-org-name":"133","paywall-org-id":"134","paywall-auth-provider":"135","paywall-logged-in":"136","publish-timestamp-gmt":"137","publish-timestamp":"138","publish-day-of-week":"139","omni-visit-id":"140","user-type":"141","a-b-test":"142","experiment-name":"143","paywall-special-product-code":"144","paywall-product-code":"145","post-options":"146","child-post-id":"147","page-variant-name":"148","pageview-id":"149"};			pmc_ga_dimensions["dimension127"] = document.location.protocol.replace(':', '');
			pmc_ga_dimensions["dimension149"] = window._skmPageViewId;
			(function(dim){
							if( 'undefined' !== typeof pmc_meta && 'string' === typeof pmc_meta.omni_visit_id ){
				dim["dimension140"] = pmc_meta.omni_visit_id;
			}
				function skmGenerateUuid() {
			return 'xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx'.replace(/[xy]/g, function(c) {
				var r = Math.random() * 16 | 0, v = c === 'x' ? r : ((r & 0x3) | 0x8);
				return v.toString(16);
			});
		};
		// 'skm-local-timestamp'.
		var date = new Date();
		pmc_ga_dimensions.dimension40 = date.getTime().toString();
		// 'skm-pageview-id'.
		// '_skmPageViewId' value might already be generated by Boomerang.
		window._skmPageViewId = window._skmPageViewId || skmGenerateUuid();
		pmc_ga_dimensions.dimension103 = window._skmPageViewId;
		pmc_ga_dimensions.dimension112 = window.location.pathname.replace( /\/$/, '' ).replace( /\/(\d+)$/, '' );
					})(pmc_ga_dimensions);

			var pmc_ga_fields_obj = {"useAmpClientId":true};
			ga('create', "UA-72491114-1", 'auto', pmc_ga_fields_obj);
			ga('set', 'forceSSL', true);

						ga('require', 'linkid', 'linkid.js');
							ga('require', 'displayfeatures');			ga('set', pmc_ga_dimensions);
			window.pmcGaCustomDimensions = pmc_ga_dimensions;
			
			
			ga('send', 'pageview');

			
		</script>

		<script src='https://soaps.sheknows.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script async="async" src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-global-functions/js/pmc-global.min.js?ver=5.8.2' id='pmc-global-functions-js'></script>
<script id='pmc-comscore-js-extra'>
var pmc_comscore_options = {"pageview_candidate_url":"\/\/soaps.sheknows.com\/wp-content\/plugins\/pmc-plugins\/pmc-comscore\/xml\/comscore-pageview-candidate.xml"};
</script>
<script async="async" src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-comscore/js/pmc-comscore.js?ver=1.1' id='pmc-comscore-js'></script>
<script type="text/javascript" src="https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-global-functions/js/pmc-hooks.js?m=1640058118g" ></script><script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-adm-v2/js/polyfill/intersection-observer.min.js?ver=0.7.0' id='pmc-intersection-observer-polyfill-js'></script>
<script id='pmc-jwplayer-js-extra'>
var pmc_jwplayer_options = {"pid":"ALJ3XQCI","cgid":"","ads_suppression":""};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-video-player/js/pmc-jwplayer.min.js?ver=2021-5' id='pmc-jwplayer-js'></script>
<script onload="pmc_jwplayer.add();"  defer='defer' src='https://content.jwplatform.com/libraries/ALJ3XQCI.js?ver=5.8.2' id='pmc-video-player-library-js'></script>
<script async="async" src='https://ads.blogherads.com/bh/1/1/1/2211000/header.js' id='pmc-async-adm-boomerang-theme-script-js'></script>
<script async="async" src='https://ads.blogherads.com/static/blogherads.js' id='pmc-async-adm-boomerang-script-js'></script>
<script type="text/javascript" src="https://iabusprivacy.pmc.com/geo-info.js"></script>
<script defer='defer' src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-ignore-ga="true" data-domain-script="bd6075c1-8168-4116-a0d7-ed3f9c029148"></script>
<script defer='defer' src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0002,C0004,SPD_BG" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="true"></script>
		
<script type="text/javascript">
	// Override the OneTrust geo location data with our own
	if ( 'object' === typeof pmc_fastly_geo_data && 'string' === typeof pmc_fastly_geo_data.region && 'string' === typeof pmc_fastly_geo_data.country) {
		var OneTrust = {
			geolocationResponse: {
				stateCode: pmc_fastly_geo_data.region,
				countryCode: pmc_fastly_geo_data.country,
			}
		}
	}

	function OptanonWrapper() {
		//Temp fix to solve cache issue
		if (
			'' === location.search &&
			'function' === typeof window.loadGA &&
			pmc_fastly_geo_data &&
			pmc_fastly_geo_data.continent &&
			'EU' !== pmc_fastly_geo_data.continent
		) {
			window.loadGA( true );
			var consent_data = {
				'returnValue': '',
				'success': true
			};
			pmc.hooks.do_action( 'pmc_adm_consent_data_ready', consent_data );
		}

		if ( 'object' === typeof pmc_onetrust ) {
			pmc_onetrust.init();
		}
	}
</script>
<link rel="https://api.w.org/" href="https://soaps.sheknows.com/wp-json/" /><meta name="generator" content="WordPress 5.8.2" />
<link rel="alternate" type="application/json+oembed" href="https://soaps.sheknows.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsoaps.sheknows.com%2Fgeneral-hospital%2Fnews%2F618351%2Fgeneral-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://soaps.sheknows.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsoaps.sheknows.com%2Fgeneral-hospital%2Fnews%2F618351%2Fgeneral-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video%2F&#038;format=xml" />
<meta name="author" content="Amy Mistretta">		<link rel="manifest" href="https://soaps.sheknows.com/wp-json/wp/v2/web-app-manifest">
		<meta name="theme-color" content="#fff">
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="mobile-web-app-capable" content="yes">
		<meta name="apple-touch-fullscreen" content="YES">
							<link rel="apple-touch-startup-image" href="https://soaps.sheknows.com/wp-content/uploads/2018/11/favicon-96x96-2.png?fit=96%2C96">
		
				<meta name="apple-mobile-web-app-title" content="Soaps.com">
		<meta name="application-name" content="Soaps.com">
				<script type="text/javascript">
			window.addEventListener('beforeinstallprompt', (e) => {
				e.preventDefault();
			});
		</script>
		
<style type="text/css">
.vvqbox {
	visibility: visible !important;
	display: block;
	clear: both;
	width: 100%;
}
.vvqbox div {
	margin: 10px auto;
}
.vvqbox img {
	max-width: 100%;
	height: 100%;
}
.vvqbox object {
	max-width: 100%;
}
</style>
<style type='text/css'>img#wpstats{display:none}</style>
				<script>
			try {
				// Don't rely on jQuery being loaded yet.
				document.addEventListener( 'DOMContentLoaded', function() {
					// Record in GA event if ads are blocked.
					if ( true === window.pmc_is_adblocked ) {
						ga( 'send', 'event', 'ad_blocker', 'blocked', 'ads_blocked', {
							nonInteraction: true
						});
					}
				});
			} catch( err ) {
				// Do nothing...
			}
		</script>
		<link rel="canonical" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" />
<meta name="robots" content="max-image-preview:large">		<script>
			!function(n){"use strict";n.loadCSS||(n.loadCSS=function(){});var o=loadCSS.relpreload={};if(o.support=function(){var e;try{e=n.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),o.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},o.poly=function(){if(!o.support())for(var t=n.document.getElementsByTagName("link"),e=0;e<t.length;e++){var a=t[e];"preload"!==a.rel||"style"!==a.getAttribute("as")||a.getAttribute("data-loadcss")||(a.setAttribute("data-loadcss",!0),o.bindMediaToggle(a))}},!o.support()){o.poly();var t=n.setInterval(o.poly,500);n.addEventListener?n.addEventListener("load",function(){o.poly(),n.clearInterval(t)}):n.attachEvent&&n.attachEvent("onload",function(){o.poly(),n.clearInterval(t)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:n.loadCSS=loadCSS}("undefined"!=typeof global?global:this);		</script>
		
<script type='text/javascript'>
	(function() {

		/** CONFIGURATION START **/
		var _sf_async_config = window._sf_async_config = ( window._sf_async_config || {} );

		_sf_async_config.uid          = 7673;
		_sf_async_config.domain       = 'soaps.sheknows.com';
		_sf_async_config.useCanonical = true;
		_sf_async_config.sections     = "General Hospital";
		_sf_async_config.authors      = "Amy Mistretta";
		/** CONFIGURATION END **/

		function loadChartbeat() {

			var e = document.createElement('script');
			var n = document.getElementsByTagName('script')[0];

			e.type  = 'text/javascript';
			e.async = true;
			e.src   = '//static.chartbeat.com/js/chartbeat.js';

			n.parentNode.insertBefore(e, n);

		}

		loadChartbeat();

	})();
</script>
<script type="text/javascript">
/* <![CDATA[ */
var pmc_site_config = {"rot13_hostname":"fbncf.furxabjf.pbz","hostname":"soaps.sheknows.com","is_proxied":null};

/* ]]> */
</script>
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "name": "Soaps.com",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
    },
    "headline": "General Hospital's Steve Burton's (Jason Morgan) Sweet Christmas Duet With His Daughter, Video",
    "datePublished": "2021-12-24T11:30:11+00:00",
    "dateModified": "2021-12-23T08:54:41+00:00",
    "description": "“Merry Christmas and Happy New Year!” It’s Christmas Eve and time for families across the globe to get together to create new holiday memories. General Hospital fave Steve Burton, who was recently let go from the ABC soap as Jason, gave his fans a glimpse inside one of his special performances with his adorable daughter [&hellip;]",
    "author": {
        "@type": "Person",
        "name": "Amy Mistretta"
    },
    "publisher": {
        "@type": "Organization",
        "name": "Soaps.com",
        "url": "https://soaps.sheknows.com",
        "logo": {
            "@type": "ImageObject",
            "url": "https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/images/logo.png"
        }
    },
    "isAccessibleForFree": "True",
    "image": {
        "@type": "ImageObject",
        "url": "https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg"
    }
}</script>
<meta name="onesignal" content="wordpress-plugin"/>
<script type="application/javascript">
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
	googletag.cmd.push(function () {
		googletag.pubads().collapseEmptyDivs();
	});
	var blogherads = blogherads || {};
	blogherads.adq = blogherads.adq || [];
	blogherads.adq.push(function() {
		var config = {
			c3: '3940384',
			options: {}
		};
	});

	(function ( blogherads ) {
		blogherads.adq.push( function () {
							blogherads.setConf( 'vertical', 'ros' );
			
			
			
			
			
			blogherads.setTargeting( 'pt', 'news' );
blogherads.setTargeting( 'ci', 'ART-618351' );
blogherads.setTargeting( 'tag', ["gh","jason-morgan","steve-burton"] );
blogherads.setTargeting( 'kw', ["gh","jason-morgan","steve-burton"] );
blogherads.setTargeting( 'admants', ["S_4117","S_4285","S_4287","S_4315","S_4316","S_4320","S_4360","S_4700","S_4828","S_4961","S_5019","S_6205","S_6310","S_6555","S_6648","S_6649","S_6651","S_6871","S_6872","S_6878","S_7075","S_7363","S_7846"] );

			blogherads.setTargeting( 'skin', Math.floor( ( Math.random() * 12 ) + 1 ).toString() );// Needed for serving mutiple campaigns

		} );
	})( blogherads );
</script>
<!-- There is no amphtml version available for this URL. -->
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Watch General Hospital&#8217;s Steve Burton Team Up With His 7-Year-Old Christmas &#8216;Angel&#8217; on a Heartwarming Holiday Duet" />
<meta property="og:url" content="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" />
<meta property="og:description" content="“Merry Christmas and Happy New Year!” It’s Christmas Eve and time for families across the globe to get together to create new holiday memories. General Hospital fave Steve Burton, who was recently …" />
<meta property="article:published_time" content="2021-12-24T11:30:11+00:00" />
<meta property="article:modified_time" content="2021-12-23T13:54:41+00:00" />
<meta property="og:site_name" content="Soaps.com" />
<meta property="og:image" content="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?fit=1231%2C718" />
<meta property="og:image:width" content="1231" />
<meta property="og:image:height" content="718" />
<meta property="og:image:alt" content="jason jj Steve Burton at the Cast Main Event during the General Hospital Fan Club Weekend at Embassy Suites Los Angeles Glendale in Glendale, California on July 27, 3019© Jill Johnson/jpistudios.com310-657-9661" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Watch General Hospital&#8217;s Steve Burton Team Up With His 7-Year-Old Christmas &#8216;Angel&#8217; on a Heartwarming Holiday Duet" />
<meta name="twitter:image" content="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?fit=1024%2C597" />
<meta name="twitter:image:alt" content="jason jj Steve Burton at the Cast Main Event during the General Hospital Fan Club Weekend at Embassy Suites Los Angeles Glendale in Glendale, California on July 27, 3019© Jill Johnson/jpistudios.com310-657-9661" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@soapoperafan" />
<meta name="twitter:title" content="Watch General Hospital&#8217;s Steve Burton Team Up With His 7-Year-Old Christmas &#8216;Angel&#8217; on a Heartwarming Holiday Duet" />
<meta name="twitter:description" content="General Hospital&#039;s Steve Burton (Jason Morgan) taped a sweet Christmas duet with his daughter and shared a video for fans." />

<!-- End Jetpack Open Graph Tags -->
<script type="text/javascript">
/* <![CDATA[ */
var pmc_krux = {"lob":"","page-type":"single-news","env":"desktop","primary-category":"","primary-vertical":"","vertical":"","category":"","tag":["GH","Jason Morgan","Steve Burton"],"author":"","logged-in":"","subscriber-type":""};

/* ]]> */
</script>
<link rel="icon" href="https://soaps.sheknows.com/wp-content/uploads/2018/11/favicon-96x96-2.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://soaps.sheknows.com/wp-content/uploads/2018/11/favicon-96x96-2.png?fit=96%2C96" sizes="192x192" />
<link rel="apple-touch-icon" href="https://soaps.sheknows.com/wp-content/uploads/2018/11/favicon-96x96-2.png?fit=96%2C96" />
<meta name="msapplication-TileImage" content="https://soaps.sheknows.com/wp-content/uploads/2018/11/favicon-96x96-2.png?fit=96%2C96" />

<script type="text/javascript">
	!function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	}(document.createElement('script'),
	document.getElementsByTagName('script')[0],
	'//cdn.taboola.com/libtrc/shemedia-soapscom/loader.js');
	window.taboolaDivCount   = 0;
	window.taboolaDivsLoaded = [];
</script>		<!-- Hotjar Tracking Code for https://soaps.sheknows.com -->
		<script type="text/javascript" class="optanon-category-C0002">
			(function(h,o,t,j,a,r){
				h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
				h._hjSettings={hjid:986255,hjsv:5};
				a=o.getElementsByTagName('head')[0];
				r=o.createElement('script');r.async=1;
				r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
				a.appendChild(r);
			})(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
		</script>
		<!-- pmc-tags-head permutive -->
<!--START Permutive Tag-->
<script type="text/javascript" class="optanon-category-C0004">
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,'3d2fb0bd-52fc-4b75-aaf5-2d436c172540','2aed5ae2-5875-450b-9e5e-34ac932123da',{});

	
	permutive.addon( 'web', {"page":{"type":"single-news","loggedIn":false,"article":{"id":"618351","title":"Watch General Hospital&#8217;s Steve Burton Team Up With His 7-Year-Old Christmas &#8216;Angel&#8217; on a Heartwarming Holiday Duet","authors":[],"section":"","publishedAt":"2021-12-24T11:30:11+00:00","keywords":["GH","Jason Morgan","Steve Burton"],"categories":[],"verticals":[],"pageLevelData":["GH","Jason Morgan","Steve Burton"],"pageAccessLevel":"","watson":{"taxonomy":"$alchemy_taxonomy","keywords":"$alchemy_keywords","entities":"$alchemy_entities","concepts":"$alchemy_concepts"}}}} );
</script>
<script type="text/javascript" class="optanon-category-C0004" src='https://cdn.permutive.com/3d2fb0bd-52fc-4b75-aaf5-2d436c172540-web.js' async></script>
<!--END Permutive Tag-->

<!--START Atlas MG Tag-->
<script type="text/javascript">
var blogherads = blogherads || {};
blogherads.adq = blogherads.adq || [];

window.pmc_fpd = {"page":{"type":"single-news","loggedIn":false},"article":{"id":"618351","title":"Watch General Hospital&#8217;s Steve Burton Team Up With His 7-Year-Old Christmas &#8216;Angel&#8217; on a Heartwarming Holiday Duet","authors":[],"section":"","publishedAt":"2021-12-24T11:30:11+00:00","keywords":["GH","Jason Morgan","Steve Burton"],"categories":[],"verticals":[],"pageLevelData":["GH","Jason Morgan","Steve Burton"],"pageAccessLevel":""}};

blogherads.adq.push(function () {
	try {
		blogherads.setPageMetaData( window.pmc_fpd );
	} catch (e) {
		// Do nothing
	}
});
</script>
<!--END Atlas MG Tag-->
<!-- end pmc-tags-head permutive --></head>
<body class="news-template-default single single-news postid-618351 pmc-desktop pmc-no-tablet pmc-no-mobile geo-us pmc-group-pmc-dev pmc-gallery__">
		<!-- Google Tag Manager -->
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TMSZZ4H"
					  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script type="text/javascript" class="optanon-category-C0004">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-TMSZZ4H');</script>
	<!-- End Google Tag Manager -->

	<!-- pmc-tags-top Comscore -->	<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035310&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" />
	</noscript>

<!-- end pmc-tags-top Comscore --><!-- pmc-tags-top Quantcast -->	<script type="text/javascript" class="optanon-category-C0002"> var _qevents = _qevents || []; (function() { var elem = document.createElement('script'); elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js"; elem.async = true; elem.type = "text/javascript"; var scpt = document.getElementsByTagName('script')[0]; scpt.parentNode.insertBefore(elem, scpt); })(); </script>

<!-- end pmc-tags-top Quantcast --><!-- pmc-tags-top Prefetch --><meta http-equiv="x-dns-prefetch-control" content="on"><link rel="dns-prefetch" href="//aax.amazon-adsystem.com"/><link rel="dns-prefetch" href="//ajax.googleapis.com"/><link rel="dns-prefetch" href="//apiservices.krxd.net"/><link rel="dns-prefetch" href="//beacon.krxd.net"/><link rel="dns-prefetch" href="//boygeniusreport.files.wordpress.com"/><link rel="dns-prefetch" href="//cdn.krxd.net"/><link rel="dns-prefetch" href="//cdn.syndication.twimg.com"/><link rel="dns-prefetch" href="//disqus.com"/><link rel="dns-prefetch" href="//edge.quantserve.com"/><link rel="dns-prefetch" href="//googleads.g.doubleclick.net"/><link rel="dns-prefetch" href="//i0.wp.com"/><link rel="dns-prefetch" href="//i1.wp.com"/><link rel="dns-prefetch" href="//i2.wp.com"/><link rel="dns-prefetch" href="//load.instinctiveads.com"/><link rel="dns-prefetch" href="//load.s3.amazonaws.com"/><link rel="dns-prefetch" href="//o.twimg.com"/><link rel="dns-prefetch" href="//p.skimresources.com"/><link rel="dns-prefetch" href="//pagead2.googlesyndication.com"/><link rel="dns-prefetch" href="//pbs.twimg.com"/><link rel="dns-prefetch" href="//pixel.quantserve.com"/><link rel="dns-prefetch" href="//pmcdeadline2.files.wordpress.com"/><link rel="dns-prefetch" href="//pmcfootwearnews.files.wordpress.com"/><link rel="dns-prefetch" href="//pmchollywoodlife.files.wordpress.com"/><link rel="dns-prefetch" href="//pmcvariety.files.wordpress.com"/><link rel="dns-prefetch" href="//r.skimresources.com"/><link rel="dns-prefetch" href="//s.gravatar.com"/><link rel="dns-prefetch" href="//s.skimresources.com"/><link rel="dns-prefetch" href="//s0.wp.com"/><link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"/><link rel="dns-prefetch" href="//stats.wordpress.com"/><link rel="dns-prefetch" href="//summits.wwd.com"/><link rel="dns-prefetch" href="//ton.twimg.com"/><link rel="dns-prefetch" href="//tpc.googlesyndication.com"/><link rel="dns-prefetch" href="//www.google-analytics.com"/><link rel="dns-prefetch" href="//www.googletagmanager.com"/><link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"/><link rel="dns-prefetch" href="//www.youtube.com"/><link rel="dns-prefetch" href="//x.skimresources.com"/><!-- end pmc-tags-top Prefetch --><!-- Placeholder for Responsive Skin Ad -->
<div id="skin-ad-section" data-content-container="main-wrapper">

	<div id="skin-ad-left-rail-container"></div>

	<div id="skin-ad-right-rail-container"></div>
	<div id="skin-ad-inject-container">
			</div>
</div>

<!-- End Placeholder for Responsive Skin Ad -->

	
			<header class="site-header">
			<div class="site-header__top">
				<div class="site-header__left pl-0">
					<button class="site-header__menu-toggle no-hover" href="#sidr">Menu</button>
					
<div class="social-links hide-for-small-only">
	<a class="social-links__facebook" target="_blank" href="https://www.facebook.com/SheKnowsSoaps/" title="Facebook">
		<span class="icon-icomoon-facebook"></span>
	</a>
	<a class="social-links__twitter" target="_blank" href="https://twitter.com/soapsdotcom" title="Twitter">
		<span class="icon-icomoon-twitter-1"></span>
	</a>
	<a class="social-links__instagram" target="_blank" href="https://www.instagram.com/soapsdotcom/" title="Instagram">
		<span class="icon-icomoon-instagram-1"></span>
	</a>
</div>
				</div>

									<h2 class="site-header__logo text-center">
									<a id="logo" title="Soap Opera News and Updates" href="https://soaps.sheknows.com">
						<img alt="Soaps.com" src="https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/images/logo.png" />
					</a>
									</h2>
				
				<div class="text-right site-header__right pr-0">
					<button id="header-search-toggle" class="site-header__search-toggle no-hover hide-for-small-only">
						<img src="https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/images/search-btn.png" alt="Search" />
					</button>

					<span class='site-header__user-sign-in'>
						<a class="site-header__login-link" target="_top" href="https://soaps.sheknows.com/message-boards/login" title="Login">
							<img src="https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/images/avatar-image.jpg" alt="Avatar Image" />
						</a>
					</span>
				</div>
			</div>
			<div id="sidr" class="site-header__menu">
	<p class="site-header__menu-title">menu</p>
	<div class="site-header__menu-popular">
		<p>Popular Shows</p>
		<ul>
			<li><a href="https://soaps.sheknows.com/the-bold-and-the-beautiful/">The Bold and the Beautiful</a></li>
			<li><a href="https://soaps.sheknows.com/days-of-our-lives/">Days of Our Lives</a></li>
			<li><a href="https://soaps.sheknows.com/general-hospital/">General Hospital</a></li>
			<li><a href="https://soaps.sheknows.com/the-young-and-the-restless/">The Young and the Restless</a></li>
		</ul>
	</div>
	<ul id="menu-main-menu" class="nav navbar-nav"><li id="menu-item-459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-459"><a href="#">All Shows</a>
<ul class="sub-menu">
	<li id="menu-item-112275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112275"><a href="/all-my-children">All My Children</a></li>
	<li id="menu-item-112276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112276"><a href="/as-the-world-turns">As the World Turns</a></li>
	<li id="menu-item-112278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112278"><a href="/days-of-our-lives">Days of Our Lives</a></li>
	<li id="menu-item-112282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112282"><a href="/general-hospital">General Hospital</a></li>
	<li id="menu-item-112285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112285"><a href="/guiding-light">Guiding LIght</a></li>
	<li id="menu-item-112286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112286"><a href="/one-life-to-live">One Life to Live</a></li>
	<li id="menu-item-112287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112287"><a href="/passions">Passions</a></li>
	<li id="menu-item-112291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112291"><a href="/the-bold-and-the-beautiful">The Bold and the Beautiful</a></li>
	<li id="menu-item-112292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112292"><a href="/the-young-and-the-restless">The Young and the Restless</a></li>
</ul>
</li>
<li id="menu-item-313993" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-313993"><a href="/recaps">Recaps</a></li>
<li id="menu-item-313994" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-313994"><a href="/spoilers">Spoilers</a></li>
<li id="menu-item-112204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112204"><a href="/news">News</a></li>
<li id="menu-item-313995" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-313995"><a href="/comings-and-goings">Comings and Goings</a></li>
<li id="menu-item-434913" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-434913"><a href="/rumor-mill">Rumor Mill</a></li>
<li id="menu-item-113907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113907"><a href="/soapbox">Soapbox</a></li>
<li id="menu-item-545653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-545653"><a href="https://soaps.sheknows.com/about-us/">About Us</a></li>
</ul>	<div class="search">
		<form class="soaps-searchform" role="search" method="get" target='_top' action="https://soaps.sheknows.com/search">
	<input type="text" name="s" class="soaps-searchform__input" placeholder="Search Soaps.com" value="" />
	<button type="submit" class="soaps-searchform__button btn btn-default">Search</button>
</form>
	</div>
	
<div class="social-links ">
	<a class="social-links__facebook" target="_blank" href="https://www.facebook.com/SheKnowsSoaps/" title="Facebook">
		<span class="icon-icomoon-facebook"></span>
	</a>
	<a class="social-links__twitter" target="_blank" href="https://twitter.com/soapsdotcom" title="Twitter">
		<span class="icon-icomoon-twitter-1"></span>
	</a>
	<a class="social-links__instagram" target="_blank" href="https://www.instagram.com/soapsdotcom/" title="Instagram">
		<span class="icon-icomoon-instagram-1"></span>
	</a>
</div>
	<div class="menu-copyright text-center">
		<p>SheKnows.com Lifestyles</p>
		<p>
			Soaps.com is a part of Penske Media Corporation. &copy; 2021 SheMedia, LLC.		</p>

		<p>All Rights Reserved</p>
	</div>
</div>

			<div id="header-search-wrap" class="site-header__search-wrap">
				<div class="row align-center">
					<div class="large-7 columns">
						<form class="soaps-searchform" role="search" method="get" target='_top' action="https://soaps.sheknows.com/search">
	<input type="text" name="s" class="soaps-searchform__input" placeholder="Search" value="" />
	<button type="submit" class="soaps-searchform__button btn btn-default">Search</button>
</form>
					</div>
				</div>
			</div>

			<div class="show-bar"><ul id="menu-main-top-menu" class="menu"><li id="menu-item-448891" class="show-item show-YR menu-item menu-item-type-custom menu-item-object-custom menu-item-448891"><a href="/the-young-and-the-restless">The Young and the Restless</a></li>
<li id="menu-item-448927" class="show-item show-DOOL menu-item menu-item-type-custom menu-item-object-custom menu-item-448927"><a href="/days-of-our-lives">Days of our Lives</a></li>
<li id="menu-item-448933" class="show-item show-BB menu-item menu-item-type-custom menu-item-object-custom menu-item-448933"><a href="/the-bold-and-the-beautiful">The Bold and the Beautiful</a></li>
<li id="menu-item-448945" class="show-item show-GH menu-item menu-item-type-custom menu-item-object-custom menu-item-448945"><a href="/general-hospital">General Hospital</a></li>
<li id="menu-item-448949" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448949"><a href="/comings-and-goings">Comings &#038; Goings</a></li>
<li id="menu-item-449259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-449259"><a href="/news">Soaps News</a></li>
<li id="menu-item-448955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-448955"><a href="/spoilers">Spoilers</a></li>
<li id="menu-item-448951" class="message-boards menu-item menu-item-type-custom menu-item-object-custom menu-item-448951"><a href="https://soaps.sheknows.com/message-boards/">Message Boards</a></li>
</ul></div>			<div id="header-ads" class="site-header__ads ads-background">
					<div class="admz" id="adm-header">
					<div class="adma boomerang" data-device="Desktop" data-width="728">
				
<div style=""
	class="pmc-adm-boomerang-pub-div ">
	<div id="skm-ad-flexbanner-top-uid0"
		class="adw-728 adh-90" data-is-adhesion-ad="">
		<script type="application/javascript">
			blogherads.adq.push(function () {
								blogherads
					.defineSlot( 'flexbanner', 'skm-ad-flexbanner-top-uid0' )
																				.addSize([[728,90],[970,90],[970,250]])
												;
							});
		</script>
	</div>
</div>
			</div>
				</div>
			</div>

		</header>
	
	<div id="site-wrap" class="site-wrap">

			<div class="row shows-gh collapse">

		<div class="small-12 columns shows-page__header">
	<div class="row align-bottom align-justify shows-page__landing">
		<div class="medium-12 small-8 columns shows-page__logo">
			<a href="https://soaps.sheknows.com/general-hospital"><img width="530" height="45" src="https://soaps.sheknows.com/wp-content/uploads/2015/07/gh_logo.png?fit=530%2C45" class="attachment-full size-full" alt="" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2015/07/gh_logo.png?w=530 530w, https://soaps.sheknows.com/wp-content/uploads/2015/07/gh_logo.png?w=300 300w, https://soaps.sheknows.com/wp-content/uploads/2015/07/gh_logo.png?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2015/07/gh_logo.png?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2015/07/gh_logo.png?w=285 285w, https://soaps.sheknows.com/wp-content/uploads/2015/07/gh_logo.png?w=320 320w" sizes="(max-width: 530px) 100vw, 530px" /></a><h3><a href="https://soaps.sheknows.com/general-hospital">General Hospital</a></h3>		</div>
		<div class="columns pl-0 text-right align-self-bottom">
			<button id="shows-menu-toggle-button" class="shows-page__menu-toggle hide-for-medium">Show Menu</button>
			<ul id="shows-menu-toggle" class="shows-page__menu">
				<li class=""><a href="https://soaps.sheknows.com/general-hospital/recaps">Recaps</a></li><li class=""><a href="https://soaps.sheknows.com/general-hospital/spoilers">Spoilers</a></li><li class=""><a href="https://soaps.sheknows.com/general-hospital/comings-and-goings">Comings &amp; Goings</a></li><li class="active"><a href="https://soaps.sheknows.com/general-hospital/news">News</a></li><li class=""><a href="https://soaps.sheknows.com/general-hospital/soapbox">Soapbox</a></li>					<li class="menu-item-has-children">
						<a href="#">
							More						</a>
						<ul class="sub-menu">
							<li><a href="https://soaps.sheknows.com/general-hospital/characters">Character List</a></li><li><a href="https://soaps.sheknows.com/general-hospital/rumor-mill">Rumor Mill</a></li><li><a href="https://soaps.sheknows.com/message-boards/c/general-hospital">Message Boards</a></li>						</ul>
					</li>
								</ul>
		</div>
	</div>
</div>
		<div id="main" class="site-main large-8 small-12 columns main-post">
			<ul class="breadcrumb">
	<li><a href="https://soaps.sheknows.com">Home</a></li><li><a href="https://soaps.sheknows.com/general-hospital">General Hospital</a></li><li>News</li></ul>

			<div class="title">
				<h1 class="main-post__title" property="name">Watch General Hospital&#8217;s Steve Burton Team Up With His 7-Year-Old Christmas &#8216;Angel&#8217; on a Heartwarming Holiday Duet</h1>
			</div>

			<div class="post-author row collapse">
						<div class="columns post-author__image-section shrink pr-0">
				<a href="https://soaps.sheknows.com/author/amy-mistretta/" title="">
					<div class="post-author__image"><img width="96" height="96" src="https://soaps.sheknows.com/wp-content/uploads/2018/11/Amy-Mistretta-38.jpg?fit=96%2C96" class="attachment-96x96 size-96x96" alt="" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2018/11/Amy-Mistretta-38.jpg?w=240 240w, https://soaps.sheknows.com/wp-content/uploads/2018/11/Amy-Mistretta-38.jpg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2018/11/Amy-Mistretta-38.jpg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2018/11/Amy-Mistretta-38.jpg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2018/11/Amy-Mistretta-38.jpg?w=110 110w" sizes="(max-width: 96px) 100vw, 96px" /></div>
				</a>
			</div>
			
	<div class="columns align-self-middle post-author__details">
		<p>
							<strong property="author">
					<a href="https://soaps.sheknows.com/author/amy-mistretta/" title="Amy Mistretta">
						Amy Mistretta					</a>
				</strong>
													</p>
		<p property="datePublished"><abbr class="card-date" title="2021-12-24T06:30:11+00:00">About 8 hours ago</abbr></p>
	</div>
</div>
<div class="row social-share-bar">
	<div class="columns small-12 medium-expand">
		<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

	</div>
	</div>

			<!--main content-->
			<div class="main-post__wrapper" role='main'>
				<div class="main-post__image">
					<img width="1230" height="717" src="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?resize=1230%2C717" class="attachment-news-single size-news-single wp-post-image" alt="jason jj Steve Burton at the Cast Main Event during the General Hospital Fan Club Weekend at Embassy Suites Los Angeles Glendale in Glendale, California on July 27, 3019© Jill Johnson/jpistudios.com310-657-9661" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=1231 1231w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=300 300w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=768 768w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=1024 1024w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=654 654w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=1020 1020w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=462 462w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=285 285w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=320 320w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=640 640w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=800 800w" sizes="(max-width: 1230px) 100vw, 1230px" />				</div>

				<p class="image-credit">Jill Johnson/JPI</p>
				<div class="main-post__content">
					<p><b>“Merry Christmas and Happy New Year!”</b></p>
<p>It’s Christmas Eve and time for families across the globe to get together to create new holiday memories. <i>General Hospital</i> fave Steve Burton, who was recently <a  href="https://soaps.sheknows.com/general-hospital/news/616027/general-hospital-steve-burton-last-day-set-photo-jason-return-soap/"  rel="noopener"  target="_blank"  >let go from the ABC soap as Jason</a>, gave his fans a glimpse inside one of his special performances with his adorable daughter Brooklyn. </p>
<p>“I’ve never fancied myself as a singer but when my 7-year-old angel/daughter Brooklyn said, ‘Daddy, let’s sing a duet for Christmas!’ How could I say no? Our producer caught this,” Burton shared along with a video of the father/daughter duo singing the Christmas classic “Let It Snow! Let It Snow! Let It Snow!” He then wished his fans a “Merry Christmas and Happy New Year” and cheered, “Brooklyn rocks!” And we have to agree, she certainly does — as does her daddy! </p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/reel/CXzmQWbhw4H/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a  href="https://www.instagram.com/reel/CXzmQWbhw4H/?utm_source=ig_embed&#038;utm_campaign=loading"  style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;"  target="_blank"  rel="nofollow"  > </p>
<div style="flex-direction: row;align-items: center">
<div style="background-color: #F4F4F4;border-radius: 50%;flex-grow: 0;height: 40px;margin-right: 14px;width: 40px"></div>
<div style="flex-direction: column;flex-grow: 1;justify-content: center">
<div style="background-color: #F4F4F4;border-radius: 4px;flex-grow: 0;height: 14px;margin-bottom: 6px;width: 100px"></div>
<div style="background-color: #F4F4F4;border-radius: 4px;flex-grow: 0;height: 14px;width: 60px"></div>
</div>
</div>
<div style="padding: 19% 0"></div>
<div style="height:50px;margin:0 auto 12px;width:50px"><svg></svg></div>
<div style="padding-top: 8px">
<div style="color:#3897f0;font-family:Arial,sans-serif;font-size:14px;font-style:normal;font-weight:550;line-height:18px">View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0"></div>
<div style="flex-direction: row;margin-bottom: 14px;align-items: center">
<div>
<div style="background-color: #F4F4F4;border-radius: 50%;height: 12.5px;width: 12.5px"></div>
<div style="background-color: #F4F4F4;height: 12.5px;width: 12.5px;flex-grow: 0;margin-right: 14px;margin-left: 2px"></div>
<div style="background-color: #F4F4F4;border-radius: 50%;height: 12.5px;width: 12.5px"></div>
</div>
<div style="margin-left: 8px">
<div style="background-color: #F4F4F4;border-radius: 50%;flex-grow: 0;height: 20px;width: 20px"></div>
<div style="width: 0;height: 0;border-top: 2px solid transparent;border-left: 6px solid #f4f4f4;border-bottom: 2px solid transparent"></div>
</div>
<div style="margin-left: auto">
<div style="width: 0px;border-top: 8px solid #F4F4F4;border-right: 8px solid transparent"></div>
<div style="background-color: #F4F4F4;flex-grow: 0;height: 12px;width: 16px"></div>
<div style="width: 0;height: 0;border-top: 8px solid #F4F4F4;border-left: 8px solid transparent"></div>
</div>
</div>
<div style="flex-direction: column;flex-grow: 1;justify-content: center;margin-bottom: 24px">
<div style="background-color: #F4F4F4;border-radius: 4px;flex-grow: 0;height: 14px;margin-bottom: 6px;width: 224px"></div>
<div style="background-color: #F4F4F4;border-radius: 4px;flex-grow: 0;height: 14px;width: 144px"></div>
</div>
<p></a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a  href="https://www.instagram.com/reel/CXzmQWbhw4H/?utm_source=ig_embed&#038;utm_campaign=loading"  style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;"  target="_blank"  rel="nofollow"  >A post shared by Steve Burton (@1steveburton)</a></p>
</div>
</blockquote>
<p><script async src="//platform.instagram.com/en_US/embeds.js"></script> </p>
<p>Fans couldn’t get enough of the sweet video and while <i>The Young and the Restless</i> actress Courtney Hope (Sally) commented, “This is precious,” Burton’s BFF and former castmate Bradford Anderson (Spinelli) had some fun of his own. A few days ago, his wife commented on <a  href="https://soaps.sheknows.com/general-hospital/news/618312/general-hospital-bradford-anderson-jason-morgan-stone-cold-photo/"  rel="noopener"  target="_blank"  >what the daytime star was wearing</a> and asked if he was trying to dress like Burton. Of his Stone Cold getup, Kimberly McCullough (ex-Robin) stated, “Pretty damn good.” </p>
<p>Before we all set out to make new holiday memories this year, take a moment to browse through our <a  href="https://soaps.sheknows.com/gallery/general-hospital-gift-guide-soap-opera-fans-photos/"  rel="noopener"  target="_blank"  ><i>General Hospital</i> gift guide</a> for some last-minute treats in the photo gallery below — you’ll even find something for that “stone cold” fan on your list! </p>
				</div>
			</div>

			
<div id="gallery-slide-show-container-611924" class="gallery-slide-show-container hidden">
	<div class="row collapse">
		<div class="large-8 medium-12 small-12 column">
			<div id="gallery-generate-611924"></div>
			<span id="gallery-slider-close-611924" class="gallery-slider__close-button"></span>
		</div>
		<div id="gallery-slider__sidebar-611924" class="large-4 medium-12 small-12 column show-for-large-only">
			<div id="sidebar2" class="ads-sidebar large-4 small-12 columns">
	<div id="sidebar2-inner" class="ads-sidebar__inner">
		<div class='ads-background spacing'>
			<div id="pmc-ads-widget-3" class="widget widget_pmc-ads-widget pinnable" data-pin="">	<div class="admz" id="adm-widget-dsk-tab-ros-rail-top">
					<div class="adma boomerang" data-device="Desktop" data-width="300">
				
<div style=""
	class="pmc-adm-boomerang-pub-div ">
	<div id="skm-ad-rail-top-uid1"
		class="adw-300 adh-250" data-is-adhesion-ad="">
		<script type="application/javascript">
			blogherads.adq.push(function () {
								blogherads
					.defineSlot( 'flexrec', 'skm-ad-rail-top-uid1' )
																				.addSize([[300,250],[300,600]])
												;
							});
		</script>
	</div>
</div>
			</div>
				</div>
</div>
<section class="module module--popular">
	<h2 class="module__heading">Most Popular</h2>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/soaps/news/617998/yellowstone-season-4-spoilers-monica-miscarriage-lead-kayce-avery/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="monica, kayce yellowstone" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/soaps/news/617998/yellowstone-season-4-spoilers-monica-miscarriage-lead-kayce-avery/">Is Yellowstone Herding the Ultimate Heartache Toward Kayce — and a Whole New Life?</a>
				</h3>
			</div>
		</article>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/days-of-our-lives/news/618341/days-of-our-lives-chrishell-stause-jason-oppenheim-selling-sunset-breakup/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Chrishell Stause buys new home days" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/days-of-our-lives/news/618341/days-of-our-lives-chrishell-stause-jason-oppenheim-selling-sunset-breakup/">Days of Our Lives Chrishell Stause Opens Up About &#039;Scary and Terrifying&#039; End of Relationship with Selling Sunset Boss</a>
				</h3>
			</div>
		</article>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="jason jj Steve Burton at the Cast Main Event during the General Hospital Fan Club Weekend at Embassy Suites Los Angeles Glendale in Glendale, California on July 27, 3019© Jill Johnson/jpistudios.com310-657-9661" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/">Watch General Hospital&#039;s Steve Burton Team Up With His 7-Year-Old Christmas &#039;Angel&#039; on a Heartwarming Holiday Duet</a>
				</h3>
			</div>
		</article>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/general-hospital/recaps/618364/general-hospital-willow-called-stand-nina-hearing/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Sonny on the stand" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/general-hospital/recaps/618364/general-hospital-willow-called-stand-nina-hearing/">After Sonny Testifies at Nina&#039;s Hearing the Assistant DA Calls [Spoiler] to the Stand</a>
				</h3>
			</div>
		</article>
	</section>
<div id="pmc-ads-widget-5" class="widget widget_pmc-ads-widget pinnable" data-pin=""><div class="soaps-right-rail-bottom-ad">	<div class="admz" id="adm-widget-dsk-tab-ros-rail-bottom">
					<div class="adma boomerang" data-device="Desktop" data-width="300">
				
<div style=""
	class="pmc-adm-boomerang-pub-div ">
	<div id="skm-ad-rail-bottom-uid2"
		class="adw-300 adh-250" data-is-adhesion-ad="">
		<script type="application/javascript">
			blogherads.adq.push(function () {
								blogherads
					.defineSlot( 'flexrec', 'skm-ad-rail-bottom-uid2' )
																				.addSize([[300,250],[300,600]])
												;
							});
		</script>
	</div>
</div>
			</div>
				</div>
</div></div>		</div>
	</div>
</div>
		</div>
	</div>
</div>

<div class="gallery-featured">
	<figure>
		<a class="gallery-link main-post__blank-gallery" id="gallery-link-611924" href="https://soaps.sheknows.com/gallery/general-hospital-gift-guide-soap-opera-fans-photos/">
			<img width="650" height="359" src="https://soaps.sheknows.com/wp-content/uploads/2021/11/gh-gift-guide-abc-etsy.jpg?resize=650%2C359" class="attachment-gallery-slide-show size-gallery-slide-show wp-post-image" alt="gh gift guide" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/11/gh-gift-guide-abc-etsy.jpg?w=125 125w, https://soaps.sheknows.com/wp-content/uploads/2021/11/gh-gift-guide-abc-etsy.jpg?w=650 650w" sizes="(max-width: 650px) 100vw, 650px" />
			<span>
				<strong>View Gallery</strong>
				<i></i>
			</span>
		</a>
	</figure>
</div>

<div id="gallery-slides-611924" class="gallery-slides">
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/pizza-maker-kit-amazon.jpeg?fit=718%2C718" alt="pizza maker kit">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/pizza-maker-kit-amazon.jpeg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Amazon					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">1</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;Enjoy a Thanksgiving like &lt;em&gt;General Hospital&rsquo;s&lt;/em&gt; Quartermaines with your very own &lt;a href=&quot;https://www.amazon.com/Chef-Boyardee-Pepperoni-Pizza-Maker/dp/B00FPLGA6C/?tag=soaps0f6-20&quot; target=&quot;_blank&quot;&gt;Chef Boyardee Pepperoni Pizza Maker kit&lt;/a&gt;. Even if you have your heart set on the traditional turkey dinner, it&rsquo;s still a good idea to keep one of these around in case the unthinkable happens and the local pizza shop is closed for the holidays! &nbsp;&nbsp;&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/guess-who-gh-game-etsy.jpg?fit=794%2C794" alt="guess who gh game">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/guess-who-gh-game-etsy.jpg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Etsy					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">2</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;Do you want the chance to test a fellow fan with a who&rsquo;s who in Port Charles? The fun &lt;a href=&quot;https://www.etsy.com/listing/1052192210/guess-who-general-hospital-theme?source=aw&amp;utm_source=affiliate_window&amp;utm_medium=affiliate&amp;utm_campaign=us_location_buyer&amp;utm_content=299513&amp;awc=6220_1634298827_25922538727f7d5fb0f46067845de883&amp;utm_term=0&quot; target=&quot;_blank&quot;&gt;Guess Who?&nbsp;&lt;em&gt;General Hospital&lt;/em&gt; board game&lt;/a&gt; will let you quiz each other with details on the show&rsquo;s various characters to see who comes out on top as being the most in-the-know when it comes to the ABC soap. &nbsp;&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/port-charles-mug-gh-etsy.jpg?fit=794%2C794" alt="port charles mug gh">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/port-charles-mug-gh-etsy.jpg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Etsy					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">3</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;If you&rsquo;d like to support your favorite fictional soap city, we have a gift for you. Pour a cup of joe, or whatever you&rsquo;d like, in this unique &lt;a href=&quot;https://www.etsy.com/listing/1046868475/port-charles-enamel-mug?source=aw&amp;utm_source=affiliate_window&amp;utm_medium=affiliate&amp;utm_campaign=us_location_buyer&amp;utm_content=299513&amp;awc=6220_1634298846_ddc30ce7c23ff4e588dce6eb0dc61e1a&amp;utm_term=0&quot; target=&quot;_blank&quot;&gt;Port Charles camper mug&lt;/a&gt;. You can even bring it to work and have a cup of soup! &nbsp;&nbsp;&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-jason-morgan-mug-amazon.jpg?fit=450%2C450" alt="gh jason morgan fan mug">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-jason-morgan-mug-amazon.jpg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Amazon					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">4</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;Are you a fan of a certain leather-jacket-wearing Port Charles hunk? Show your support by drinking out of this &lt;a href=&quot;https://www.amazon.com/General-Hospital-Mug-Coffee-Stocking/dp/B07L22YJZM/?tag=soaps0f6-20&quot; target=&quot;_blank&quot;&gt;Jason Morgan mug&lt;/a&gt; and letting everyone who sees you know that &ldquo;there can only be one&rdquo; Stone Cold.&nbsp;&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/charlies-pub-glass-gh-amazon.jpg?fit=320%2C320" alt="charlie&#039;s pub mug gh">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/charlies-pub-glass-gh-amazon.jpg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Amazon					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">5</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;This is the perfect gift to add to your entertaining area. While having a drink in a &lt;a href=&quot;https://www.amazon.com/General-Hospital-Charlies-Laser-Engraved/dp/B0983VYJQ9/?tag=soaps0f6-20&quot; target=&quot;_blank&quot;&gt;Charlie&rsquo;s Pub glass&lt;/a&gt; with friends at your bar, it&rsquo;ll be fun explaining just where the pub is actually located.&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-coasters-amazon.jpg?fit=679%2C688" alt="gh coasters">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-coasters-amazon.jpg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: amazon					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">6</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;You&rsquo;ll also need some coasters to set your pub glass on. This neat &lt;a href=&quot;https://www.amazon.com/General-Hospital-Charles-Coasters-Mahogany/dp/B08ZJG3D1K/?tag=soaps0f6-20&quot; target=&quot;_blank&quot;&gt;&lt;em&gt;General Hospital&lt;/em&gt; coaster set&lt;/a&gt; contains four well-known Port Charles locales including Charlie&rsquo;s Pub, Kelly&rsquo;s, Perks Coffee and The Floating Rib.&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-fan-shirt-amazon.jpg?fit=315%2C320" alt="gh fan shirt">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-fan-shirt-amazon.jpg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: amazon					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">7</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;Men, women and children alike can sport this &lt;a href=&quot;https://www.amazon.com/General-Hospital-Fan-Shirt/dp/B07P9LTWH4/?tag=soaps0f6-20&quot; target=&quot;_blank&quot;&gt;#1 &lt;em&gt;General Hospital&lt;/em&gt; Fan t-shirt&lt;/a&gt;. It comes in many sizes and colors, including black, blue, cranberry and green, for the whole family.&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-binge-watching-tshirt-amazon.jpeg?fit=718%2C729" alt="binge-watching gh tshirt">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-binge-watching-tshirt-amazon.jpeg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Amazon					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">8</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;Do you watch the soap daily or DVR it for weekend viewing? If you do the latter, and end up getting wrangled into weekend chores, wearing this &lt;a href=&quot;https://www.amazon.com/General-Hospital-Binge-Watching-T-Shirt/dp/B07YYSJ518?tag=soaps0f6-20&quot; target=&quot;_blank&quot;&gt;&lt;em&gt;General Hospital&lt;/em&gt; t-shirt&lt;/a&gt; will let everyone know exactly what you&#8217;d rather be doing.&nbsp;&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-socks-amazon.png?fit=400%2C699" alt="gh socks">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-socks-amazon.png" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Amazon					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">9</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;And if you&rsquo;re watching the soap and don&rsquo;t want to be interrupted &mdash; no matter what chores need to be done &mdash; we have you covered. Wearing these &lt;a href=&quot;https://www.amazon.com/General-Hospital-Charles-Officially-Licensed/dp/B08R435D54/?tag=soaps0f6-20&quot; target=&quot;_blank&quot;&gt;&lt;em&gt;General Hospital&lt;/em&gt; socks&lt;/a&gt; will get your message across loud and clear!&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-onesie-etsy.jpg?fit=718%2C989" alt="gh onesie">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-onesie-etsy.jpg" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: Etsy					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">10</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;Plus, if you are a mom who needs an extra backup excuse to watch your favorite daytime drama, try putting your little one in this adorable &lt;a href=&quot;https://www.etsy.com/listing/723155244/shhh-im-watching-general-hospital-with?source=aw&amp;utm_source=affiliate_window&amp;utm_medium=affiliate&amp;utm_campaign=us_location_buyer&amp;utm_content=299513&amp;awc=6220_1634298866_040ec9d9100dda15da5df183cb91132d&amp;utm_term=0&quot; target=&quot;_blank&quot;&gt;&lt;em&gt;General Hospital&lt;/em&gt; onesie&lt;/a&gt;. The message speaks for itself! &nbsp;&nbsp;&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
			<div class="gallery-slides__slide">
			<div class="gallery-slides__separator"></div>
			<div class="gallery-slides__slide-image-container">
				<figure class="gallery-slides__slide-figure" itemprop="thumbnail" itemscope itemtype="https://schema.org/ImageObject">
					<img class="gallery-slide_slide-image" src="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-candy-heart-blanket-abc.png?fit=718%2C832" alt="gh candy heart blanket">
				</figure>
				<a href="https://soaps.sheknows.com/wp-content/uploads/2021/10/gh-candy-heart-blanket-abc.png" class="gallery-slides__magnify-link thickbox magnify-icon">
					<i class="icon-icomoon-zoom-in"></i>
				</a>
			</div>
			<div class="gallery-slides__footer">
									<div class="gallery-slides__image-credit" itemprop="creator">
						Image: ABC					</div>
							</div>

			<div class="gallery-slides__header">
				<span class="gallery-slides__current-slide-count">11</span>/<span class="gallery-slides__total-slide-count">11</span>
				<h2 class="gallery-slides__slide-title" itemprop="alternativeHeadline">&lt;p&gt;Candy hearts and Valentine&rsquo;s Day go hand-in-hand but no one said they couldn&rsquo;t be gifted during other occasions as well &mdash; in the form of a blanket! The fan on your holiday list will love the &lt;a href=&quot;https://shopabctv.com/collections/general-hospital/products/general-hospital-candy-hearts-sherpa-blanket&quot; target=&quot;_blank&quot;&gt;&lt;em&gt;General Hospital&lt;/em&gt; Sherpa blanket&lt;/a&gt; featuring romantic candy heart messages surrounding your favorite characters. &nbsp;&nbsp;&lt;/p&gt;
</h2>
			</div>

			<div class="gallery-slides__social-links share-text-buttons">
				<svg xmlns="http://www.w3.org/2000/svg" style="display:none;" height="0" width="0">
<symbol id="pmc-social-share-bar-comment" viewBox="0 0 1792 1792"><path d="M1792 896q0 174-120 321.5t-326 233-450 85.5q-70 0-145-8-198 175-460 242-49 14-114 22-17 2-30.5-9t-17.5-29v-1q-3-4-.5-12t2-10 4.5-9.5l6-9 7-8.5 8-9q7-8 31-34.5t34.5-38 31-39.5 32.5-51 27-59 26-76q-157-89-247.5-220t-90.5-281q0-130 71-248.5t191-204.5 286-136.5 348-50.5q244 0 450 85.5t326 233 120 321.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-email" viewBox="0 0 1792 1792"><path d="M1792 710v794q0 66-47 113t-113 47H160q-66 0-113-47T0 1504V710q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38T639 1015q-91-64-262-182.5T172 690q-62-42-117-115.5T0 438q0-78 41.5-130T160 256h1472q65 0 112.5 47t47.5 113z"/>
</symbol>
<symbol id="pmc-social-share-bar-facebook" viewBox="0 0 1792 1792"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759H734V905H479V609h255V391q0-186 104-288.5T1115 0q147 0 228 12z"/>
</symbol>
<symbol id="pmc-social-share-bar-linkedin" viewBox="0 0 1792 1792"><path d="M477 625v991h-330v-991h330zm21-306q1 73-50.5 122t-135.5 49h-2q-82 0-132-49t-50-122q0-74 51.5-122.5t134.5-48.5 133 48.5 51 122.5zm1166 729v568h-329v-530q0-105-40.5-164.5t-126.5-59.5q-63 0-105.5 34.5t-63.5 85.5q-11 30-11 81v553h-329q2-399 2-647t-1-296l-1-48h329v144h-2q20-32 41-56t56.5-52 87-43.5 114.5-15.5q171 0 275 113.5t104 332.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-pinit" viewBox="0 0 1792 1792"><path d="M1664 896q0 209-103 385.5T1281.5 1561 896 1664q-111 0-218-32 59-93 78-164 9-34 54-211 20 39 73 67.5t114 28.5q121 0 216-68.5t147-188.5 52-270q0-114-59.5-214T1180 449t-255-63q-105 0-196 29t-154.5 77-109 110.5-67 129.5T377 866q0 104 40 183t117 111q30 12 38-20 2-7 8-31t8-30q6-23-11-43-51-61-51-151 0-151 104.5-259.5T904 517q151 0 235.5 82t84.5 213q0 170-68.5 289T980 1220q-61 0-98-43.5T859 1072q8-35 26.5-93.5t30-103T927 800q0-50-27-83t-77-33q-62 0-105 57t-43 142q0 73 25 122l-99 418q-17 70-13 177-206-91-333-281T128 896q0-209 103-385.5T510.5 231 896 128t385.5 103T1561 510.5 1664 896z"/>
</symbol>
<symbol id="pmc-social-share-bar-show-more" viewBox="0 0 1792 1792"><path d="M1600 736v192q0 40-28 68t-68 28h-416v416q0 40-28 68t-68 28h-192q-40 0-68-28t-28-68v-416h-416q-40 0-68-28t-28-68v-192q0-40 28-68t68-28h416v-416q0-40 28-68t68-28h192q40 0 68 28t28 68v416h416q40 0 68 28t28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-print" viewBox="0 0 1792 1792"><path d="M448 1536h896v-256h-896v256zm0-640h896v-384h-160q-40 0-68-28t-28-68v-160h-640v640zm1152 64q0-26-19-45t-45-19-45 19-19 45 19 45 45 19 45-19 19-45zm128 0v416q0 13-9.5 22.5t-22.5 9.5h-224v160q0 40-28 68t-68 28h-960q-40 0-68-28t-28-68v-160h-224q-13 0-22.5-9.5t-9.5-22.5v-416q0-79 56.5-135.5t135.5-56.5h64v-544q0-40 28-68t68-28h672q40 0 88 20t76 48l152 152q28 28 48 76t20 88v256h64q79 0 135.5 56.5t56.5 135.5z"/>
</symbol>
<symbol id="pmc-social-share-bar-reddit" viewBox="0 0 1792 1792"><path d="M1095 1167q16 16 0 31-62 62-199 62t-199-62q-16-15 0-31 6-6 15-6t15 6q48 49 169 49 120 0 169-49 6-6 15-6t15 6zM788 986q0 37-26 63t-63 26-63.5-26-26.5-63q0-38 26.5-64t63.5-26 63 26.5 26 63.5zm395 0q0 37-26.5 63t-63.5 26-63-26-26-63 26-63.5 63-26.5 63.5 26 26.5 64zm251-120q0-49-35-84t-85-35-86 36q-130-90-311-96l63-283 200 45q0 37 26 63t63 26 63.5-26.5T1359 448t-26.5-63.5T1269 358q-54 0-80 50l-221-49q-19-5-25 16l-69 312q-180 7-309 97-35-37-87-37-50 0-85 35t-35 84q0 35 18.5 64t49.5 44q-6 27-6 56 0 142 140 243t337 101q198 0 338-101t140-243q0-32-7-57 30-15 48-43.5t18-63.5zm358 30q0 182-71 348t-191 286-286 191-348 71-348-71-286-191-191-286T0 896t71-348 191-286T548 71 896 0t348 71 286 191 191 286 71 348z"/>
</symbol>
<symbol id="pmc-social-share-bar-close" viewBox="0 0 1792 1792"><path d="M1490 1322q0 40-28 68l-136 136q-28 28-68 28t-68-28l-294-294-294 294q-28 28-68 28t-68-28l-136-136q-28-28-28-68t28-68l294-294-294-294q-28-28-28-68t28-68l136-136q28-28 68-28t68 28l294 294 294-294q28-28 68-28t68 28l136 136q28 28 28 68t-28 68l-294 294 294 294q28 28 28 68z"/>
</symbol>
<symbol id="pmc-social-share-bar-tumblr" viewBox="0 0 1792 1792"><path d="M1328 1329l80 237q-23 35-111 66t-177 32q-104 2-190.5-26T787 1564t-95-106-55.5-120-16.5-118V676H452V461q72-26 129-69.5t91-90 58-102 34-99T779 12q1-5 4.5-8.5T791 0h244v424h333v252h-334v518q0 30 6.5 56t22.5 52.5 49.5 41.5 81.5 14q78-2 134-29z"/>
</symbol>
<symbol id="pmc-social-share-bar-twitter" viewBox="0 0 1792 1792"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5T1369.5 1125 1185 1335.5t-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5T285 1033q33 5 61 5 43 0 85-11-112-23-185.5-111.5T172 710v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5T884 653q-8-38-8-74 0-134 94.5-228.5T1199 256q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/>
</symbol>
<symbol id="pmc-social-share-bar-whatsapp" viewBox="0 0 1792 1792"><path d="M1113 974q13 0 97.5 44t89.5 53q2 5 2 15 0 33-17 76-16 39-71 65.5t-102 26.5q-57 0-190-62-98-45-170-118t-148-185q-72-107-71-194v-8q3-91 74-158 24-22 52-22 6 0 18 1.5t19 1.5q19 0 26.5 6.5t15.5 27.5q8 20 33 88t25 75q0 21-34.5 57.5t-34.5 46.5q0 7 5 15 34 73 102 137 56 53 151 101 12 7 22 7 15 0 54-48.5t52-48.5zm-203 530q127 0 243.5-50t200.5-134 134-200.5 50-243.5-50-243.5-134-200.5-200.5-134-243.5-50-243.5 50-200.5 134-134 200.5-50 243.5q0 203 120 368l-79 233 242-77q158 104 345 104zm0-1382q153 0 292.5 60t240.5 161 161 240.5 60 292.5-60 292.5-161 240.5-240.5 161-292.5 60q-195 0-365-94l-417 134 136-405q-108-178-108-389 0-153 60-292.5t161-240.5 240.5-161 292.5-60z"/>
</symbol></svg><div class="share-container">
	<ul class="share-buttons">
					<li>
									<a data-href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button" href="https://www.facebook.com/sharer.php?u=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;sdk=joey&#038;display=popup&#038;ref=plugin&#038;src=share_button"
				 					class="btn-facebook"
											target="_blank"
											title="Share on Facebook">
						<svg>
							<use xlink:href="#pmc-social-share-bar-facebook"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan" href="https://twitter.com/intent/tweet?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;text=Watch%20General%20Hospital%E2%80%99s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20%E2%80%98Angel%E2%80%99%20on%20a%20Heartwarming%20Holiday%20Duet&#038;via=soapoperafan"
				 					class="btn-twitter"
											target="_blank"
											title="Tweet">
						<svg>
							<use xlink:href="#pmc-social-share-bar-twitter"></use>
						</svg>
											</a>
				</li>
						<li>
									<a data-href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://pinterest.com/pin/create/link/?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;description=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
				 					class="btn-pinterest"
											target="_blank"
											title="Pin it">
						<svg>
							<use xlink:href="#pmc-social-share-bar-pinit"></use>
						</svg>
											</a>
				</li>
							<li>
					<a href="#share-more" class="showShareMore btn-more" target="_blank" title="More Share Options">
					<svg>
						<use xlink:href="#pmc-social-share-bar-show-more"></use>
					</svg>
				</a>
			</li>
		</ul>
	<div class="shareMore">
		<ul class="shareModal">
			<li>
				Share This Article				<a class="closeShare" href="#closeShare">
					<svg>
						<use xlink:href="#pmc-social-share-bar-close"></use>
					</svg>
				</a>
			</li>
							<li>
											<a data-href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="https://www.reddit.com/submit?url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-reddit"
											target="_blank"
																title="Submit to Reddit">
						<svg>
							<use xlink:href="#pmc-social-share-bar-reddit"></use>
						</svg>
						<span>
							Reddit						</span>
					</a>
				</li>
							<li>
											<a data-href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan" href="https://www.linkedin.com/shareArticle?mini=1&#038;url=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/&#038;title=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;summary&#038;source=soapoperafan"
											class="btn-linkedin"
											target="_blank"
																title="Share on LinkedIn">
						<svg>
							<use xlink:href="#pmc-social-share-bar-linkedin"></use>
						</svg>
						<span>
							LinkedIn						</span>
					</a>
				</li>
							<li>
											<a data-href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/" href="whatsapp://send?text=Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet%20-%20https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
											class="btn-whatsapp"
																data-action="share/whatsapp/share"
											title="Share on WhatsApp">
						<svg>
							<use xlink:href="#pmc-social-share-bar-whatsapp"></use>
						</svg>
						<span>
							WhatsApp						</span>
					</a>
				</li>
							<li>
											<a data-href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet" href="mailto:?subject=soapoperafan%20:%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet&#038;body=https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/%20-%20Watch%20General%20Hospital’s%20Steve%20Burton%20Team%20Up%20With%20His%207-Year-Old%20Christmas%20‘Angel’%20on%20a%20Heartwarming%20Holiday%20Duet"
											class="btn-email"
											target="_blank"
																title="Email">
						<svg>
							<use xlink:href="#pmc-social-share-bar-email"></use>
						</svg>
						<span>
							Email						</span>
					</a>
				</li>
							<li>
											<a href="javascript:window.print()"
											class="btn-print"
																title="Print This Page">
						<svg>
							<use xlink:href="#pmc-social-share-bar-print"></use>
						</svg>
						<span>
							Print						</span>
					</a>
				</li>
							<li>
											<a data-href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond" href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/#respond"
											class="btn-comment"
																title="Talk">
						<svg>
							<use xlink:href="#pmc-social-share-bar-comment"></use>
						</svg>
						<span>
							Talk						</span>
					</a>
				</li>
					</ul>
	</div>
</div>

			</div>
		</div>
	</div>
<footer class="entry-footer">
	<div class="c-tags"><h4 class="tags-title">Tagged in</h4> <a href="https://soaps.sheknows.com/tag/gh/" rel="tag">GH</a> <a href="https://soaps.sheknows.com/tag/jason-morgan/" rel="tag">Jason Morgan</a> <a href="https://soaps.sheknows.com/tag/steve-burton/" rel="tag">Steve Burton</a></div></footer>

			<div class="post-pagination row collapse">
	<div class="column">
					<a href="https://soaps.sheknows.com/general-hospital/news/618312/general-hospital-bradford-anderson-jason-morgan-stone-cold-photo/">
				<div class="post-pagination__prev">
					<div class="post-pagination__img"></div>
					<div class="post-pagination__title hide-for-small-only">
						<p class="">Previous in News</p>						<span>General Hospital&#039;s Bradford Anderson...</span>
					</div>
				</div>
			</a>
				</div>

	<div class="column">
					<a href="https://soaps.sheknows.com/general-hospital/news/618459/general-hospital-preview-scott-cross-examines-willow-carly-worries/">
				<div class="post-pagination__next">
					<div class="post-pagination__title hide-for-small-only">
						<p class="">Next in News</p>						<span>General Hospital Preview: Scott...</span>
					</div>
					<div class="post-pagination__img"></div>
				</div>
			</a>
				</div>
</div>


<div id="taboola-below-article-thumbnails"></div>

<script type="text/javascript">
	if ( 'undefined' !== window.taboolaDivCount && -1 === document.cookie.indexOf('scroll0=') ) {
		document.getElementById("taboola-below-article-thumbnails").setAttribute("id", "taboola-below-article-thumbnails-" + window.taboolaDivCount);

		if (0 === window.taboolaDivCount) {
			window._taboola = window._taboola || [];

			_taboola.push({
				mode: 'thumbnails-a',
				container: "taboola-below-article-thumbnails-" + window.taboolaDivCount,
				placement: 'Below Article Thumbnails',
				target_type: 'mix'
		 	});

			_taboola.push({
				article: 'auto',
				url: 'https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/'
			});

			window.taboolaDivsLoaded[window.taboolaDivCount] = true;
		} else {
			window.taboolaDivsLoaded[window.taboolaDivCount] = false;
		}

		window.taboolaDivCount++;
	}
</script>

			<div id="comments-anchor" class="spot-im-comments comments-area">
        <script async
            data-spotim-module="spotim-launcher"
            data-article-tags="GH, Jason Morgan, Steve Burton"
            src="https://launcher.spot.im/spot/sp_39y75fhy"
            data-post-id="618351"
            data-post-url="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
            data-short-url="https://soaps.sheknows.com/?p=618351"
            data-messages-count="40"
            data-wp-import-endpoint="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/feed/spotim/"
            data-facebook-url="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
            data-disqus-shortname="sheknowssoaps"
            data-disqus-url="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/"
            data-disqus-identifier="618351 https://soaps.sheknows.com/?p=618351"
            data-community-question=""
            data-seo-enabled="false"
            data-wp-v="p-4.4.0/wp-5.8.2"
    ></script>
    </div>

		</div>

		<div id="sidebar1" class="large-4 small-12 columns">
	<div id="pmc-ads-widget-3" class="widget widget_pmc-ads-widget pinnable" data-pin="">	<div class="admz" id="adm-widget-dsk-tab-ros-rail-top">
					<div class="adma boomerang" data-device="Desktop" data-width="300">
				
<div style=""
	class="pmc-adm-boomerang-pub-div ">
	<div id="skm-ad-rail-top-uid3"
		class="adw-300 adh-250" data-is-adhesion-ad="">
		<script type="application/javascript">
			blogherads.adq.push(function () {
								blogherads
					.defineSlot( 'flexrec', 'skm-ad-rail-top-uid3' )
																				.addSize([[300,250],[300,600]])
												;
							});
		</script>
	</div>
</div>
			</div>
				</div>
</div>
<section class="module module--popular">
	<h2 class="module__heading">Most Popular</h2>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/soaps/news/617998/yellowstone-season-4-spoilers-monica-miscarriage-lead-kayce-avery/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="monica, kayce yellowstone" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/12/Monica-Kayce-trouble-Yellowstone-Paramount.jpg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/soaps/news/617998/yellowstone-season-4-spoilers-monica-miscarriage-lead-kayce-avery/">Is Yellowstone Herding the Ultimate Heartache Toward Kayce — and a Whole New Life?</a>
				</h3>
			</div>
		</article>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/days-of-our-lives/news/618341/days-of-our-lives-chrishell-stause-jason-oppenheim-selling-sunset-breakup/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Chrishell Stause buys new home days" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/06/Chrishell-Stause-buys-new-home-days-jp.jpg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/days-of-our-lives/news/618341/days-of-our-lives-chrishell-stause-jason-oppenheim-selling-sunset-breakup/">Days of Our Lives Chrishell Stause Opens Up About &#039;Scary and Terrifying&#039; End of Relationship with Selling Sunset Boss</a>
				</h3>
			</div>
		</article>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="jason jj Steve Burton at the Cast Main Event during the General Hospital Fan Club Weekend at Embassy Suites Los Angeles Glendale in Glendale, California on July 27, 3019© Jill Johnson/jpistudios.com310-657-9661" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/08/steve-burton-jason-jj.jpeg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/general-hospital/news/618351/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video/">Watch General Hospital&#039;s Steve Burton Team Up With His 7-Year-Old Christmas &#039;Angel&#039; on a Heartwarming Holiday Duet</a>
				</h3>
			</div>
		</article>
			<article class="module-article">
			<div class="module-article__thumbnail featured-image">
				<a href="https://soaps.sheknows.com/general-hospital/recaps/618364/general-hospital-willow-called-stand-nina-hearing/">
					<img width="150" height="150" src="https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?resize=150%2C150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Sonny on the stand" loading="lazy" srcset="https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=150 150w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=100 100w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=148 148w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=110 110w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=550 550w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?w=470 470w, https://soaps.sheknows.com/wp-content/uploads/2021/12/sonny-on-stand-gh-abc.jpg?zoom=2&amp;resize=150%2C150 300w" sizes="(max-width: 150px) 100vw, 150px" />				</a>
			</div>
			<div class="module-article__heading">
				<h3>
					<a href="https://soaps.sheknows.com/general-hospital/recaps/618364/general-hospital-willow-called-stand-nina-hearing/">After Sonny Testifies at Nina&#039;s Hearing the Assistant DA Calls [Spoiler] to the Stand</a>
				</h3>
			</div>
		</article>
	</section>
<div id="pmc-ads-widget-5" class="widget widget_pmc-ads-widget pinnable" data-pin=""><div class="soaps-right-rail-bottom-ad">	<div class="admz" id="adm-widget-dsk-tab-ros-rail-bottom">
					<div class="adma boomerang" data-device="Desktop" data-width="300">
				
<div style=""
	class="pmc-adm-boomerang-pub-div ">
	<div id="skm-ad-rail-bottom-uid4"
		class="adw-300 adh-250" data-is-adhesion-ad="">
		<script type="application/javascript">
			blogherads.adq.push(function () {
								blogherads
					.defineSlot( 'flexrec', 'skm-ad-rail-bottom-uid4' )
																				.addSize([[300,250],[300,600]])
												;
							});
		</script>
	</div>
</div>
			</div>
				</div>
</div></div></div>

	</div>
	
		</div><!-- /.site-wrap -->

		<div id="site-footer" ></div>

		<div id="ad-placement-footer" class="columns site-footer__ads spacing">
				<div class="admz" id="adm-footer">
					<div class="adma boomerang" data-device="Desktop" data-width="728">
				
<div style=""
	class="pmc-adm-boomerang-pub-div ">
	<div id="skm-ad-footer-banner-uid5"
		class="adw-728 adh-90" data-is-adhesion-ad="">
		<script type="application/javascript">
			blogherads.adq.push(function () {
								blogherads
					.defineSlot( 'banner', 'skm-ad-footer-banner-uid5' )
																				.addSize([[728,90]])
												;
							});
		</script>
	</div>
</div>
			</div>
				</div>
		</div>

		
<section class="news-wire row">

	<div class="large-12 medium-12 small-12 columns" >
		<h2 class="news-wire__heading section-header">
			<span>Newswire</span>
		</h2>
	</div>

	<div class="news-wire__header large-12 medium-12 small-12 columns">
		<div class="news-wire__powered-by">
			<div class="news-wire__powered-by-text">
				Powered by			</div>
			<div class="news-wire__powered-by-logo"></div>
		</div>
	</div>

	<div class="news-wire_articles large-12 medium-12 small-12 columns">
		<div class="row">
			
<div class="news-wire__item large-3 medium-3 small-6 columns">

	<article class="news-wire__article">
		<a href="https://hollywoodlife.com/2021/12/24/chris-brown-son-aeko-beanie-winter-jacket-photo/">
			<figure class="news-wire__image">

				<div class="news-wire__cropped-image">

					
					<img src="//hollywoodlife.com/wp-content/uploads/2021/12/chrisbrownaeko_feat.jpg?w=230&#038;crop=1&#038;w=300" alt="" class="news-wire__img" width="300" height="171">

				</div>

			</figure>

			<div class="news-wire__article-header">

				<div class="news-wire__article-brand">
					<span class="screen-reader-text">Posted on:</span> HollywoodLife				</div>

				<h3 class="news-wire__article-heading">
					Chris Brown’s Son Aeko, 2, Looks His Dad’s Twin In Beanie &amp; Puffy Jacket For Winter				</h3>

				<div class="news-wire__article-timestamp">
					<span class="screen-reader-text">Posted</span>
					4 hours ago				</div>

			</div>
		</a>
	</article>

</div>

<div class="news-wire__item large-3 medium-3 small-6 columns">

	<article class="news-wire__article">
		<a href="https://variety.com/2021/artisans/global/aardman-shaun-the-sheep-the-flight-before-christmas-1235143195/">
			<figure class="news-wire__image">

				<div class="news-wire__cropped-image">

					
					<img src="//variety.com/wp-content/uploads/2021/12/Shaun-the-Sheep-The-Flight-Before-Christmas_BTS_CJ_20210504_767.jpg?w=230&#038;crop=1&#038;w=300" alt="" class="news-wire__img" width="300" height="171">

				</div>

			</figure>

			<div class="news-wire__article-header">

				<div class="news-wire__article-brand">
					<span class="screen-reader-text">Posted on:</span> Variety				</div>

				<h3 class="news-wire__article-heading">
					How Aardman Delivered ‘Shaun the Sheep: The Flight Before Christmas’ During a Pandemic				</h3>

				<div class="news-wire__article-timestamp">
					<span class="screen-reader-text">Posted</span>
					5 hours ago				</div>

			</div>
		</a>
	</article>

</div>

<div class="news-wire__item large-3 medium-3 small-6 columns">

	<article class="news-wire__article">
		<a href="https://deadline.com/2021/12/alec-baldwin-instagram-holiday-video-rust-shooting-1234901611/">
			<figure class="news-wire__image">

				<div class="news-wire__cropped-image">

					
					<img src="//deadline.com/wp-content/uploads/2021/01/MEGA498114_024-e1611013915826.jpg?w=230&#038;crop=1&#038;w=300" alt="" class="news-wire__img" width="300" height="171">

				</div>

			</figure>

			<div class="news-wire__article-header">

				<div class="news-wire__article-brand">
					<span class="screen-reader-text">Posted on:</span> Deadline				</div>

				<h3 class="news-wire__article-heading">
					Alec Baldwin Says “Not A Day Goes By I Don’t Think About” ‘Rust’ Tragedy				</h3>

				<div class="news-wire__article-timestamp">
					<span class="screen-reader-text">Posted</span>
					5 hours ago				</div>

			</div>
		</a>
	</article>

</div>

<div class="news-wire__item large-3 medium-3 small-6 columns">

	<article class="news-wire__article">
		<a href="https://tvline.com/2021/12/24/dynasty-season-5-steven-returning-tv-questions-answers/">
			<figure class="news-wire__image">

				<div class="news-wire__cropped-image">

					
					<img src="//tvline.com/wp-content/uploads/2021/12/dynasty-steven.jpg?w=230&#038;crop=1&#038;w=300" alt="" class="news-wire__img" width="300" height="171">

				</div>

			</figure>

			<div class="news-wire__article-header">

				<div class="news-wire__article-brand">
					<span class="screen-reader-text">Posted on:</span> TVLine				</div>

				<h3 class="news-wire__article-heading">
					Is Dynasty Readying a Big Return? Was Stanford&#039;s Exit Berger-Like? Hawkeye Reunion Green Screen? And More Qs!				</h3>

				<div class="news-wire__article-timestamp">
					<span class="screen-reader-text">Posted</span>
					5 hours ago				</div>

			</div>
		</a>
	</article>

</div>
		</div>
	</div>

</section>

		<div class="back-to-top">
			<a href="#" class="back-to-top__link" >Back to Top</a>
		</div>

		<footer class="site-footer">
	<div class="site-footer__wrap row">
		<div class="site-footer__nav">
			<nav class="site-footer__menu">

				<div class="site-footer__cover">
					<a href="https://soaps.sheknows.com">
						<img alt="Soaps.com" src="https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/images/logo.png" />
					</a>
				</div><!-- .site-footer__cover -->

			</nav><!-- .site-footer__menu -->
			<nav class="site-footer__menu site-footer__menu--wide">
				
<div class="footer-nav footer-nav--2-columns" data-dropdown>
	<ul class="footer-nav__list">
		<li class="footer-nav__item footer-nav__item--heading is-active" data-ripple="inverted">
			<span class="footer-nav__link t-bold footer-navigation-title">SheKnows Lifestyles</span>
		</li><!-- .footer-nav__item -->

		<li class="footer-nav__item"><a href="https://soaps.sheknows.com/recaps" class="footer-nav__link " title="Soap Opera Recaps" >Soap Opera Recaps</a></li><li class="footer-nav__item"><a href="https://soaps.sheknows.com/spoilers" class="footer-nav__link " title="Soap Opera Spoilers" >Soap Opera Spoilers</a></li><li class="footer-nav__item"><a href="https://soaps.sheknows.com/news" class="footer-nav__link " title="Soap Opera News" >Soap Opera News</a></li><li class="footer-nav__item"><a href="https://soaps.sheknows.com/comings-and-goings" class="footer-nav__link " title="Soap Opera Comings &amp; Goings" >Soap Opera Comings &amp; Goings</a></li><li class="footer-nav__item"><a href="https://soaps.sheknows.com/soapbox" class="footer-nav__link " title="Soapbox" >Soapbox</a></li><li class="footer-nav__item"><a href="https://soaps.sheknows.com/message-boards/" class="footer-nav__link " title="Soap Opera Fan Community" >Soap Opera Fan Community</a></li>
	</ul><!-- .footer-nav__list -->
</div><!-- .footer-nav -->
			</nav><!-- .site-footer__menu--wide -->
			<nav class="site-footer__menu">
				<div class="footer-nav footer-nav--1-column">
	<ul class="footer-nav__list">
		<li class="footer-nav__item footer-nav__item--heading is-active">
			<span class="footer-nav__link footer-navigation-title">Legal</span>
		</li><!-- .footer-nav__item -->

		<li class="footer-nav__item"><a href="https://pmc.com/privacy-policy/" class="footer-nav__link " title="Privacy Policy" >Privacy Policy</a></li><li class="footer-nav__item"><a href="https://pmc.com/terms-of-use/" class="footer-nav__link " title="Terms of Use" >Terms of Use</a></li><li class="footer-nav__item"><a href="https://pmc.com/privacy-policy/#california" class="footer-nav__link " title="California Privacy Rights" >California Privacy Rights</a></li><li class="footer-nav__item"><a href="https://optout.aboutads.info/" class="footer-nav__link " title="AdChoices" >AdChoices</a></li><li class="footer-nav__item"><a href="https://pmc.com/opt-out" class="footer-nav__link " title="Do Not Sell My Personal Information" >Do Not Sell My Personal Information</a></li>		<li class="footer-nav__item">
			<a id="button-privacy-preferences" href="#" class="footer-nav__link privacy-consent" target="_blank">
				EU Privacy Preferences			</a>
		</li>
	</ul><!-- .footer-nav__list -->
</div><!-- .footer-nav -->
			</nav><!-- .site-footer__menu -->
			<nav class="site-footer__menu">
				
<div class="footer-nav footer-nav--1-column" data-dropdown>
	<ul class="footer-nav__list">
		<li class="footer-nav__item footer-nav__item--heading is-active">
			<span class="footer-nav__link t-bold footer-navigation-title">Connect With Us</span>
		</li><!-- .footer-nav__item -->

		<li class="footer-nav__item"><a href="https://www.facebook.com/SheKnowsSoaps/" class="footer-nav__link " title="Facebook" ><span class="footer-nav__icon icon-icomoon-facebook"></span>Facebook</a></li><li class="footer-nav__item"><a href="https://twitter.com/soapoperafan" class="footer-nav__link " title="Twitter" ><span class="footer-nav__icon icon-icomoon-twitter"></span>Twitter</a></li><li class="footer-nav__item"><a href="https://www.instagram.com/soapsdotcom/" class="footer-nav__link " title="Instagram" ><span class="footer-nav__icon icon-icomoon-instagram"></span>Instagram</a></li>
	</ul><!-- .footer-nav__list -->
</div><!-- .footer-nav -->
			</nav><!-- .site-footer__menu -->
		</div><!-- .site-footer__nav -->

	</div><!-- .site-footer__wrap -->

	<div class="c-pmc-footer">
	<div class="c-pmc-footer__wrap row">

		<div class="c-pmc-footer__logo">
			<a href="https://www.pmc.com">
				<svg><use xlink:href="#svg-pmc-logo-black"></use></svg>
			</a>
		</div>

		<div class="c-pmc-footer__legal">
			Soaps.com is a part of Penske Media Corporation. &copy; 2021 SheMedia, LLC. All Rights Reserved.<br />Powered by WordPress.com VIP		</div>

		<div class="c-pmc-footer__dropdown c-pmc-footer--desktop" tabindex="0">
			<h4 class="c-pmc-footer__dropdown-trigger">Our Brands</h4>
			<ul class="c-pmc-footer__dropdown-contents" tabindex="0">
									<li><a class="c-pmc-footer__brand" href="https://variety.com/">Variety</a></li>
										<li><a class="c-pmc-footer__brand" href="https://deadline.com/">Deadline</a></li>
										<li><a class="c-pmc-footer__brand" href="https://www.rollingstone.com/">Rolling Stone</a></li>
										<li><a class="c-pmc-footer__brand" href="https://wwd.com/">WWD</a></li>
										<li><a class="c-pmc-footer__brand" href="https://hollywoodlife.com/">HollywoodLife</a></li>
										<li><a class="c-pmc-footer__brand" href="https://www.goldderby.com/">Gold Derby</a></li>
										<li><a class="c-pmc-footer__brand" href="https://spy.com/">Spy</a></li>
										<li><a class="c-pmc-footer__brand" href="https://robbreport.com/">Robb Report</a></li>
										<li><a class="c-pmc-footer__brand" href="https://footwearnews.com/">Footwear News</a></li>
										<li><a class="c-pmc-footer__brand" href="https://bgr.com/">BGR</a></li>
										<li><a class="c-pmc-footer__brand" href="https://www.indiewire.com/">IndieWire</a></li>
										<li><a class="c-pmc-footer__brand" href="https://sourcingjournal.com/">Sourcing Journal</a></li>
										<li><a class="c-pmc-footer__brand" href="https://tvline.com/">TVLine</a></li>
										<li><a class="c-pmc-footer__brand" href="https://fairchildlive.com/">Fairchild Media</a></li>
										<li><a class="c-pmc-footer__brand" href="https://www.sheknows.com/">She Knows</a></li>
					
			</ul>
		</div>

	</div>

	<div class="site-footer__wrap c-pmc-footer--mobile">
		<div class="site-footer__nav">
			<nav class="site-footer__menu site-footer__menu--wide">
				<div class="footer-nav footer-nav--pmc-footer footer-nav--1-column" data-dropdown="" data-collapsed-height="46px" data-expanded-height="148px">
					<ul class="footer-nav__list">
						<li class="footer-nav__item footer-nav__item--heading is-active" data-ripple="">
							<span class="footer-nav__link">Our Brands</span>
						</li><!-- .footer-nav__item -->
													<li class="footer-nav__item"><a class="footer-nav__link" href="https://variety.com/">Variety</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://deadline.com/">Deadline</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://www.rollingstone.com/">Rolling Stone</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://wwd.com/">WWD</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://hollywoodlife.com/">HollywoodLife</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://www.goldderby.com/">Gold Derby</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://spy.com/">Spy</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://robbreport.com/">Robb Report</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://footwearnews.com/">Footwear News</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://bgr.com/">BGR</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://www.indiewire.com/">IndieWire</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://sourcingjournal.com/">Sourcing Journal</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://tvline.com/">TVLine</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://fairchildlive.com/">Fairchild Media</a></li>
														<li class="footer-nav__item"><a class="footer-nav__link" href="https://www.sheknows.com/">She Knows</a></li>
												</ul><!-- .footer-nav__list -->
				</div><!-- .footer-nav -->
			</nav>
		</div>
	</div>

</div>

</footer><!-- .site-footer -->
		<div id="pmc-ad-bait" class="pub_300x250 pub_300x250m pub_728x90 text-ad textAd text_ad text_ads text-ads text-ad-links" style="width: 0 !important; height: 0 !important; position: fixed !important; left: -99999px !important;">ad</div>

		<script>
			if ( 'undefined' !== typeof jQuery ) {
				var $pmc_ad_bait = jQuery('#pmc-ad-bait');
				if ( $pmc_ad_bait.length ) {
					if ( 'block' !== $pmc_ad_bait.css('display') ) {
						window.pmc_is_adblocked = true;
					}
				}
			}
		</script>
		<div id="pmc-gallery-modal"></div><script>
	var ccpa = document.querySelector( "a[href='https:\/\/pmc.com\/opt-out']" );
	var gdpr = document.querySelector( "#button-privacy-preferences" );
	var ca_privacy_link = document.querySelector( "a[href='https:\/\/pmc.com\/privacy-policy\/#california']" );

	ccpa = ( ccpa.parentNode.nodeName.toLowerCase() === 'li' ) ? ccpa.parentElement : ccpa;
	gdpr = ( gdpr.parentNode.nodeName.toLowerCase() === 'li' ) ? gdpr.parentElement : gdpr;
	ca_privacy_link = ( ca_privacy_link.parentNode.nodeName.toLowerCase() === 'li' ) ? ca_privacy_link.parentElement : ca_privacy_link;

	if ( ccpa && gdpr && ca_privacy_link ) {
		if ( pmc_fastly_geo_data.region !== 'CA' && pmc_fastly_geo_data.continent !== 'EU' ) {
			ccpa.remove();
			gdpr.remove();
			ca_privacy_link.remove();
		} else if ( pmc_fastly_geo_data.region === 'CA' ) {
			gdpr.remove();

			ccpa.addEventListener("click", function( e ) {
				e.preventDefault();
				OneTrust.ToggleInfoDisplay();
			} );
		} else if (  pmc_fastly_geo_data.continent === 'EU' ) {
			ccpa.remove();
			ca_privacy_link.remove();

			gdpr.addEventListener("click", function( e ) {
				e.preventDefault();
				OneTrust.ToggleInfoDisplay();
			} );
		}
	}
</script>
<script async
        src="https://launcher.spot.im/spot/sp_39y75fhy?module=newsfeed"
        data-spotim-module="spotim-launcher"
        data-wp-v="p-4.4.0/wp-5.8.2"
></script>

<script id="template-pmc-gallery-611924" type="text/x-handlebars-template">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</script>
	<script>
		if ( navigator.serviceWorker ) {
			window.addEventListener( 'load', function() {
									{
						navigator.serviceWorker.register(
							"https:\/\/soaps.sheknows.com\/wp.serviceworker",
							{"scope":"\/"}						).then( reg => {
													} );
					}
							} );
		}
	</script>
	<script src='https://soaps.sheknows.com/wp-content/mu-plugins/jetpack-10.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://soaps.sheknows.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script id='pmc-video-player-ads-js-js-extra'>
var pmc_video_player_ads = {"is_jwplayer_cc_enabled":"0"};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-video-player/js/video-ads.min.js?ver=2021-5' id='pmc-video-player-ads-js-js'></script>
<script id='pmc-social-share-bar-frontend-js-js-extra'>
var pmc_share_bar_lob_ga_tracking = {"permalink":"https:\/\/soaps.sheknows.com\/general-hospital\/news\/618351\/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video\/","is_mobile":"","share_list":{"facebook":{"name":"Facebook","title":"Share on Facebook","class":"btn-facebook","url":"https:\/\/www.facebook.com\/sharer.php","popup":true,"javascript":false,"popup_title":"Share on Facebook"},"twitter":{"name":"Twitter","title":"Tweet","class":"btn-twitter","url":"https:\/\/twitter.com\/intent\/tweet","popup":true,"javascript":false,"popup_title":"Share on Twitter"},"pinit":{"name":"Pin It","title":"Pin it","class":"btn-pinterest","url":"https:\/\/pinterest.com\/pin\/create\/link\/","popup":true,"javascript":false,"popup_title":"Share on Pinterest"},"reddit":{"name":"Reddit","title":"Submit to Reddit","class":"btn-reddit","url":"https:\/\/www.reddit.com\/submit","popup":true,"javascript":false,"popup_title":"Share on Reddit"},"linkedin":{"name":"LinkedIn","title":"Share on LinkedIn","class":"btn-linkedin","url":"https:\/\/www.linkedin.com\/shareArticle","popup":true,"javascript":false,"popup_title":"Share on LinkedIn"},"whatsapp":{"name":"WhatsApp","title":"Share on WhatsApp","class":"btn-whatsapp","url":"whatsapp:\/\/send","popup":false,"javascript":false,"popup_title":"Share on Whats App"},"email":{"name":"Email","title":"Email","class":"btn-email","url":"mailto:","popup":true,"javascript":false,"popup_title":"Send an Email"},"print":{"name":"Print","title":"Print This Page","class":"btn-print","url":"javascript:window.print()","popup":false,"javascript":true,"popup_title":"Print the Article"},"comment":{"name":"Talk","title":"Talk","class":"btn-comment","url":"","popup":false,"javascript":false,"popup_title":"Post a Comment"}}};
</script>
<script async="async" src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-social-share-bar/_build/js/frontend.js?ver=1.0' id='pmc-social-share-bar-frontend-js-js'></script>
<script async="async" src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-social-share-bar/_build/js/tracking.js?ver=1.0' id='pmc-social-share-bar-tracking-js-js'></script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-partner-scroll/assets/js/scroll-scripts.js?ver=2021.1' id='pmc-scroll-scripts-js'></script>
<script id='disqus_count-js-extra'>
var countVars = {"disqusShortname":"sheknowssoaps"};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/disqus-3.0/public/js/comment_count.js?ver=3.0.16' id='disqus_count-js'></script>
<script id='disqus_embed-js-extra'>
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"618351 https:\/\/soaps.sheknows.com\/?post_type=news&p=618351","disqusShortname":"sheknowssoaps","disqusTitle":"Watch General Hospital\u2019s Steve Burton Team Up With His 7-Year-Old Christmas \u2018Angel\u2019 on a Heartwarming Holiday Duet","disqusUrl":"https:\/\/soaps.sheknows.com\/general-hospital\/news\/618351\/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video\/","postId":"618351"};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/disqus-3.0/public/js/comment_embed.js?ver=3.0.16' id='disqus_embed-js'></script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-js-libraries/vendor/pmc-jquery-extensions/1.0/pmc-jquery-extensions.min.js?ver=1.0' id='pmc-jquery-extensions-js'></script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-js-libraries/vendor/jquery-inview/1.0/jquery-inview.min.js?ver=1.0' id='jquery-inview-js'></script>
<script id='pmc-ga-event-tracking-js-extra'>
var pmc_ga_event_tracking = {"events":[{"action":"click","selector":"a[custom-ga-track=click]","custom":true},{"action":"click","selector":"article a[href*=\"mktp.cc\"]","category":"affiliate_link","custom":true,"url":true},{"category":"SocialShare","label":"Network: Facebook; Location: [LOCATION]; View: [DEVICE]","action":"click","selector":"a.social-links__facebook"},{"category":"SocialShare","label":"Network: Twitter; Location: [LOCATION]; View: [DEVICE]","action":"click","selector":"a.social-links__twitter"}],"device":"[D]"};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-google-universal-analytics/js/event-tracking.min.js?ver=2.4' id='pmc-ga-event-tracking-js'></script>
<script src='https://soaps.sheknows.com/wp-content/themes/vip/pmc-core-v2/assets/build/js/site.bundle.js?ver=5.8.2' id='pmc-core-site-js-js'></script>
<script id='pmc-adm-contextual-player-js-extra'>
var pmc_adm_config = {"contextual_on_direct_sold":"remove"};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-adm-v2/js/contextual-player.min.js?ver=2021.9' id='pmc-adm-contextual-player-js'></script>
<script async="async" src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-adm-v2//js/boomerang/build/index.js?ver=2021.9' id='pmc-async-adm-boomerang-client-js-js'></script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-js-libraries/vendor/scrolltofixed/1.0/jquery-scrolltofixed.min.js?ver=1.0' id='pmc-scrolltofixed-js'></script>
<script id='pmc_sticky_rail_ads-js-js-extra'>
var pmc_sticky_rail_ads = {"rail_selector":"div#sidebar1","first_ad_selector":"","second_ad_selector":".soaps-right-rail-bottom-ad","nav_bar_selector":"","admin_bar_selector":"","first_ad_limit":"1000","ad_container_width":"320","is_dynamic_content":""};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/pmc-sticky-rail-ads//assets/js/sticky-rail-ads.min.js?ver=1.0.0' id='pmc_sticky_rail_ads-js-js'></script>
<script id='soaps-main-js-js-extra'>
var mainExports = {"i10n":{"share":"Share","tweet":"Tweet","pin":"Pin"}};
var soapsGAEvents = {"facebook":{"category":"SocialShare","label":"Path: \/general-hospital\/news\/618351\/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video\/; Page Type: News; Page number: 1; Location: body; View: [DEVICE]","action":"ShareArticle-Facebook","selector":".share-buttons a.btn-facebook"},"twitter":{"category":"SocialShare","label":"Path: \/general-hospital\/news\/618351\/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video\/; Page Type: News; Page number: 1; Location: body; View: [DEVICE]","action":"ShareArticle-Twitter","selector":".share-buttons a.btn-twitter"},"pinit":{"category":"SocialShare","label":"Path: \/general-hospital\/news\/618351\/general-hospital-steve-burton-jason-morgan-christmas-duet-daughter-video\/; Page Type: News; Page number: 1; Location: body; View: [DEVICE]","action":"ShareArticle-Pinterest","selector":".share-buttons a.btn-pinterest"}};
</script>
<script src='https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/js/main.js?ver=1640058118' id='soaps-main-js-js'></script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/soaps.sheknows.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script src='https://soaps.sheknows.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script id='soaps-single-js-js-extra'>
var singleExports = {"facebookAppID":"189672948217096"};
</script>
<script src='https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/js/single.js?ver=1640058118' id='soaps-single-js-js'></script>
<script id='soaps-gallery-js-js-extra'>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</script>
<script src='https://soaps.sheknows.com/wp-content/themes/vip/pmc-soaps-2018/assets/build/js/gallery.js?ver=1640058118' id='soaps-gallery-js-js'></script>
<script src='https://soaps.sheknows.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.8.2' async='async' id='onesignal_remote_sdk-js'></script>
<script id='onesignal_sdk_initialize-js-extra'>
var oneSignalConfig = {"default_url":"https:\/\/soaps.sheknows.com","initOptions":{"wordpress":true,"appId":"6207208f-b366-4573-9358-c7969f0fb5ef","welcomeNotification":{"disable":true},"path":"https:\/\/soaps.sheknows.com\/onesignal-api\/js\/","safari_web_id":"web.onesignal.auto.5ccade99-0f35-4775-9ae0-5e2c3bfd110b","promptOptions":[]},"should_initialize_sdk":"","should_prompt_auto_register":"","should_use_native_prompt":"","should_use_modal_prompt":"","service_worker_updater_path":"updater","service_worker_path":"worker","service_worker_scope":"\/pmc-onesignal.serviceworker\/","should_use_pmc_custom_sdk_init":"1"};
</script>
<script src='https://soaps.sheknows.com/wp-content/plugins/pmc-plugins/onesignal-free-web-push-notifications/sdk_files/init.js?ver=1.2' id='onesignal_sdk_initialize-js'></script>
<script src='https://stats.wp.com/e-202151.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4',blog:'150122077',post:'618351',tz:'-5',srv:'soaps.sheknows.com'} ]);
	_stq.push([ 'clickTrackerInit', '150122077', '618351' ]);
</script>
<!-- pmc-tags-bottom Comscore -->
	<script type="text/javascript" class="optanon-category-C0002">
		var comscore_vals = { c1: "2", c2: "6035310", c3: "", c4: "", c5: "", c6: "", c15: "" };
		var _comscore = _comscore || []; _comscore.push(comscore_vals); (function() { var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js"; el.parentNode.insertBefore(s, el); })();

		// Added to ensure that Comscore tags are triggered to fire on each slide of galleries
		(function(history){
			var pushState = history.pushState;
			history.pushState = function(state) {
			if (typeof history.onpushstate == "function") {
				history.onpushstate({state: state});
			}

			return pushState.apply(history, arguments);
			}
		})(window.history);

		// Trigger comscore beacon on change location.href
		window.onpopstate = history.onpushstate = function() {
			if ( COMSCORE !== undefined ) {
				setTimeout( function() {
					COMSCORE.beacon(comscore_vals);
				}, 1);
			}
		};
	</script>
<!-- end pmc-tags-bottom Comscore --><!-- pmc-tags-bottom Global --><!-- START callback function for onhashchange(when the hash tag in the url gets updated) -->
<script type="text/javascript">
window.pmc = window.pmc || {};
window.pmc.analytics = window.pmc.analytics || [];

function global_urlhashchanged() {
	/**
	 * Track pageview
	 */
	// Build the current domain name
	var tmp_td = document.domain.split('.');
	var tracking_domain = tmp_td[tmp_td.length-2] + "." + tmp_td[tmp_td.length-1];

	// Build the current image
	var imgname = location.hash.replace('#','');
	try {
        window.pmc.analytics.push(function() {
            window.pmc.analytics.track_pageview( location.pathname + location.hash );
		});
	} catch(err) {}

	try {
		if ( typeof window.snowplowKW == 'function' ) {
			console.log('sending tracking code');
			window.snowplowKW( 'trackPageView' );
		}
	} catch ( err ) {
	}

	// Track Quantcast
	try {

		// need to reset the array containing the options previously sent
		// as quantcast does not send the same key twice.
		if (__qc && __qc.qpixelsent && __qc.qpixelsent.length > 0) {
			__qc.qpixelsent.length = 0;
		}
		// First Quantcast Tag
		_qoptions={
			qacct:""
		};

		quantserve();

	} catch(err) {}

	// Track Comscore
	try {
		setTimeout(function(){ var url = "http" + (/^https:/.test(document.location.href) ? "s" : "") + "://beacon.scorecardresearch.com/scripts/beacon.dll" + "?c1=2&amp;c2=6035310&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c7=" + escape(document.location.href) + "&amp;c8=" + escape(document.title) + "&amp;c9=" + escape(document.referrer) + "&amp;c10=" + escape(screen.width+'x'+screen.height) + "&amp;rn=" + (new Date()).getTime(); var i = new Image(); i.src = url; }, 1);

		COMSCORE.beacon({c1:2,c2:"6035310",c3:"6035310",c4:"",c5:"",c6:"",c15:""});

	} catch(err) {}

	
	/**
	* Track pageview end
	*/
}
</script>
<!-- end pmc-tags-bottom Global --><!-- pmc-tags-bottom Digioh -->
<!--START Lightbox Javascript-->
<script type="text/javascript" class="optanon-category-C0004">
	var scrollSubscriber = document.cookie.indexOf("scroll0=") > -1;

	if ( ! scrollSubscriber ) {
		var digiohVisitorFromEmail = !! 0;

		(function(){
			window.setTimeout(
				function() {
					var tag = document.createElement( 'script' );
					tag.type = "text/javascript";
					tag.src   = "https://www.lightboxcdn.com/vendor/57bbe30e-2627-4542-8154-88b292909456/lightbox_inline.js";
					tag.async = true;

					var parent = document.getElementsByTagName( 'script' )[0];
					parent.parentNode.insertBefore( tag, parent );
				},
				500
			);
		})();
	}
</script>
<!--END Lightbox Javascript-->

<!-- end pmc-tags-bottom Digioh --><!-- pmc-tags-bottom Quantcast -->
	<script type="text/javascript" class="optanon-category-C0002">
		_qevents.push( { qacct:"p-31f3D02tYU8zY" } ); // Blog network operator	</script>
	<noscript>
		<div style="display:none;">
		<img src="//pixel.quantserve.com/pixel?a.1=&#038;a.2=p-31f3D02tYU8zY" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
	</noscript>
<!-- end pmc-tags-bottom Quantcast --><!-- pmc-tags-bottom SkimLinks -->
<script type="text/javascript" class="optanon-category-C0004" src="https://s.skimresources.com/js/87443X1620084.skimlinks.js" async></script>
<!-- end pmc-tags-bottom SkimLinks --><!-- pmc-tags-bottom Pinit -->	<!-- get credit in Pinterest's algorithm for user sharing -->
	<script type="text/javascript" class="optanon-category-C0004" src="//assets.pinterest.com/js/pinit.js" async defer></script>
<!-- end pmc-tags-bottom Pinit --><!-- pmc-tags-bottom Pingdom --><!-- DO NOT REMOVE, comment for engineering, 4BAfe4nkpyAktm3S -->
<!-- end pmc-tags-bottom Pingdom --><!-- Start: Localize Video Player Events -->
<script type="text/javascript">
/* <![CDATA[ */
	var pmc_video_player_event_tracking = {"basic":{"autoplay":"0","content_consumed":"0","play":"0","_100_percent_played":"0","error":"0","show_ad":"0","skip_ad":"0"},"advanced":{"pause":"0","seconds_played":{"_5":"0","_10":"0","_30":"0","_60":"0","_90":"0","_120":"0","_300":"0","_600":"0"},"percent_played":{"_5":"0","_10":"0","_25":"0","_50":"0","_75":"0","_95":"0"},"jump_forward":"0","jump_backward":"0","mute":"0","unmute":"0","volume_up":"0","volume_down":"0","settings":"0","full_screen":"0","watch_on_youtube":"0"}};
/* ]]> */
</script>
<!-- End: Localize Video Player Events -->
<!-- pmc-tags-footer Scroll -->
<script type="text/javascript" class="optanon-category-C0003" async src="https://static.scroll.com/js/scroll.js"></script>
<!-- end pmc-tags-footer Scroll -->
	</body>
</html>
